ProLiant Servers - Netservers

Netserver E800 - IDE UDMA support

 
JGH Eichbaum
New Member

Netserver E800 - IDE UDMA support

I recently installed Fedora Core 5 out of the box on my netserver e800. I am booting from a SCSI raid 0 and mount /home from a volumegroup (2x IDE harddisk) on the first IDE controller.
Both IDE harddisks are fully capable of UDMA, however linux does not seem to recognize this and I end up with a very bad performance. The cables are UDMA compatible and worked fine on another computer.

hdparm /dev/hda shows me:

/dev/hda:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 30401/255/63, sectors = 488397168, start = 0


This even shows that I am running in 16 bit mode and this is not desired:-( anyone can help me?
Thanks Hans
2 REPLIES 2
CA1036363
Frequent Advisor

Re: Netserver E800 - IDE UDMA support

Hans,

The Netserver E series wa built with SCSI disks in mind. The IDE channel was for peripherals (i.e. CD-ROM drive).

There have been lots of folks who have tried to run IDE drives but spend so much time trying to figure this out. Save yourself some pain and use SCSI drives.

Hope this helps.
JGH Eichbaum
New Member

Re: Netserver E800 - IDE UDMA support

David,

Thanks, I have to agree with you. Although its not an option. IDE is cheap storage. After posting this message I learned that many people had problems with the ServerWorks (Broadcom) OSB4 controller in UDMA mode. When I forced UDMA mode the disks locked up. Buying SCSI discs is really not an option, so I ended up doing this:

- upgrade the bios, the older bios let the harddisks spindown after 30 seconds idle
- put the harddisks on the IDE controller into multiword DMA (not as fast and good as UDMA) but works. 'hdparm -X34 /dev/hda' did the job

The performance went from something like 3mb/s to 14mb/s. Still not very satisfactory, but it was a first achievement.

Eventually I just replaced the controller by a promise UDMA -133 controller. the read speed on my ide drives (tested with hdparm -Tt /dev/hdX) is now 57mb/s (now we're talking).

The megaraid controller with a raid0 configuration of 2 hd's of each 18.2gb 10.000rpm) gives me just 24 MB/s! this is something I have to look in or is this just normal?