ProLiant Servers - Netservers

Netserver LH 6000, NETRAID and Linux

 
CA1284421
New Member

Netserver LH 6000, NETRAID and Linux

I am trying to get Linux loaded on the LH 6000 and having trouble with the NETRAID RAID controller.

The documentation says that RH 6.0 will work, but every time I try to install RH 6.0, it fails with a Kernel Panic. I would like to install a later version of Linux on these boxes but none seem to access the NETRAID controller. Any and all help would be appreciated.

Thorndike
5 REPLIES 5
CA1349166
New Member

Re: Netserver LH 6000, NETRAID and Linux

I have similar problem. Have a HP LH 6000r with integrated MegaRAID and it worked fine recently under Feodra Core 4 but kernel complaint about old BIOS/ACPI so I upgraded it to the 4.06.45 PU and when loading a megaraid kernel module system stops. I have downloaded new drivers from www.lsil.com and will try those when I got back home. As far as I remember before upgrade the bios version was 4.06.26 and it worked. If I only could get those files I would downgrade and don't care about acpi.

Regards

Chris
Sean T. Craig
Honored Contributor

Re: Netserver LH 6000, NETRAID and Linux

Hi Robert,

It sounds like you need to specify the driver for the embedded NetRAID so that the O/S knows how to access the drives. It will be called MRAID or MEGARAID or something along those lines. Also, HP does not currently charge for phone support on this model of Netserver. They can walk you through finding/specifying the correct NetRAID driver. The phone number is 1-800-633-3600 Opt. 1, 2, then say "Netserver Running Linux" or "Proliant Running Linux" at the prompt. It is the same team that supports linux on both product lines.

Chris,

Your situation is not similar to this one. Please post your question in a new thread. People responding to posts appreciate receiving points for good advice and you can only assign them if you are the originator of the post.

Best of luck,

Sean T. Craig Sr. C.E.T., M.C.P.

I am King...of my apartment.
Sean T. Craig
Honored Contributor

Re: Netserver LH 6000, NETRAID and Linux

Hi Again Robert,

I just checked the Operating System Support page found here:
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=lpn14552&locale=en_US&taskId=115&prodSeriesId=77403&prodTypeId=15351
and it says that RH6.0 is not supported on this server. Looks like you need 6.1 or better.

Check it out and let us know,

Sean T. Craig Sr. C.E.T., M.C.P.

I am King...of my apartment.
Robert_431
New Member

Re: Netserver LH 6000, NETRAID and Linux

Thanks for the info. I have discovered that Ubuntu and Kubuntu have the appropriate drivers installed in the kernel so the NETRAID controller is recognized right off.

If anyone from HP is reading this, it would be a blessing if they could migrate their software tools to current linux platforms!

Thanks!

Thorndike
Andreas Appenheimer
New Member

Re: Netserver LH 6000, NETRAID and Linux

Hi Robert,

I got those errors, when I'm installing CentOS 4.2.

You can use any old linux-distribution, because the used driver is as old as the hardware.

But, the message behind this failure is, u need a bios-upgrade for the NetRAID Controller.

Now, the CentOS4.2 with kernel 2.6.15.3 works very fine with the standard lsi-driver.

Regards
Andreas