ProLiant Servers - Netservers

P410 controller problem

Occasional Visitor

P410 controller problem

Hi folks


Hoping someone can help me out here as I have been going crazy trying to figure this out over the last couple of weeks.


Im having issues with a Smart Array P410 controller with 512MB FBWC module connected to 4 x 2TB SATA drives in a RAID-5 array installed in a HP Proliant Microserver N36L running Windows Server 2012.


Apologies if this is the wrong forum, but is more geared for the SA controller (rather than the server) as the fault appears to be there..


However, recently have noticed that when the server boots and running POST, were no longer getting the Smart Array Option F8 prompt or able to launch ORCA. 


This was intermittent at first (couple of weeks ago), but became more and more inconsistent later now to the point that it doesn't appear at all.


My initial thoughts were while it still was intermittent was that it may have been a firmware issue - I upgraded to v6.00 several weeks ago - then downgraded to 5.70 again - as an advisory warning stated that there were issues with v6.00 with some BL blade servers





At the BIOS summary screen (just before the OS boots) it shows that the PCIe in slot 1 as RAID and using IRQ10 (however don't always see this summary either…)


Looking at the LEDs on the card, the only active LED is the last one - DS1

According to the HP Smart Array Controllers for HP ProLiant Servers User Guide, DS1 is: 

Diagnostics Error - One of the server diagnostics utilities has detected a controller error.


However, can't find any more info on what this means..


The LEDs on the FBWC module seems to be OK (i.e. just solid green - no amber nor flashing), so this is obviously being recognised by the SA410.



Other steps taken (some while the card was intermittently functioning others once it no longer appeared):


- Powered down server, removed all cables and removed / reinserted adapter card

- Removed other adapter in PCIe x1 slot (nVidia Display Adapter) so just the SA410 in the PCIe x16 slot was installed

- Upgraded to latest firmware for Microserver (just in case..)

- Cleared system board CMOS with jumper

- Put SA410 into another system - same result

- Changed various BIOS settings i.e. disable LAN, change AHCI to RAID and IDE for on-board card 

- Getting BSOD (or equiv) in WS2012


I have looked around on the HP Support Center page as well to no avail..




So Im thinking the SA410 has locked up somehow and not totally dead - given the LEDs function as before?


If so, is there a way to reset / clear the config on the P410 somehow via some undocumented jumper (or shorting something somewhere on the adapter board)? 


Finally, if I replace the SA410 (I have ordered another in case) can I just replace the adapter and it will reinstate the RAID info intact i.e. pick the Logical Drive info from the disks and give you a drive config mismatch?



Again, huge thanks in advance for your help.








P.S. This thread has been moevd from ProLiant > ProLiant Servers (ML,DL,SL) to ProLiant Servers - Netservers. - Hp forum Moderator

Mark Matthews
Respected Contributor

Re: P410 controller problem

Hi Richard,


I've no experience with the Microservers at all but have the following suggestions re the Array controller...

Try removing the cache module from the main card. I've seen faulty modules lock up a controller like that before. You normally get a "Controller locked" type message on POST, but it could be a Microserver thing if you're not seeing that...?

As far as I know there is no 'hardware' way to reset or clear a controller via jumpers or similar, it can only be done via ACU or ORCA.


Finally, array information is shared between the controller and the disks.
If you were to replace the controller it should pickup the relevant info from the disks and carry on as normal.

Hope that helped?


Please click the white Kudos star to the left if this post is helpful :)
Occasional Visitor

Re: P410 controller problem

Hi Mark


Thanks for the reply..!


Yeah, tried it by removing the FWBC module - no change.


Curious in that the LEDs on the FWBC module show "normal state", where the P410 has the stuck DS1 LED..


From the past, I have normally seen the Smart Array error messages pop up after the Smart Array Option ROM loads i.e. 17xx eror etc.. However not even seeing th Option ROM initialisation line now...grrr.


Also what is wierd is that the card seemed to degrade over a period of time and that it is registers at the BIOS summary screen.


Hopefully the replacement should arrive shortly from the US (i'm in Melbourne, AU) and thanks for the advice on replacement - I know the older ones could do it i.e. SA 5i, 6i, 221, etc. - just wanted to be doubly sure.. :-)








Occasional Visitor

Re: P410 controller problem

Hi all


Thanks for your help and advice..


The replacement P410 arrived and appears to work OK now..


Will keep an eye on it and report if anything is wrong (the other one was intermittently failing more and more..