ProLiant Servers - Netservers

Proliant ML110 G4 serial port problem

 
Marcos David
Occasional Contributor

Proliant ML110 G4 serial port problem

Hi,
We have a HP Proliant ML110 G4 server and we are experiencing several problems with the onboard serial ports.
We have some equipment connected to these ports and an application that is communicating with the equipments. After a reboot everything is working fine, but after 5-10 minutes the communication breaks up. After a close inspection we detected the following problem: our application sets the COM1 port to 9600 8N1, after some time the settings change to 57600 7E1. We are sure there isn't any other application interfering with the port.
I've been looking around in the foruns and found some other problems related to the onboard serial ports and iLO. Is it possible there something in the BIOS interfering with the settings? Perhaps the System Event Logging or the IPMI? I've disabled everything in the BIOS but I am still experiencing problems.
Any help would be appreciated.
Thanks in advance.
3 REPLIES 3
Marcos David
Occasional Contributor

Re: Proliant ML110 G4 serial port problem

Hi, I still haven't found a solution for this problem. Any help would be apreciated.

Thanks in advance.
Ian Oldham
Occasional Advisor

Re: Proliant ML110 G4 serial port problem

Resurrecting an old thread here, I see no point in making a new one if this one has not been answered!! So im Bumping!

I have just had 2 Proliant ML110 G4 servers fail with the exact same problem thats been described here, except we noticed the problem starting when the DSR line jammed up and even after we closed our software the DSR line is still stuck on we reset the serial port setings, DSR line still stuck on.... not good.

The only way round it is to reset the machine then do the same thing 10-15 mins down the line, we got a HP engineer out to fix the first one they just replaced the motherboard. But said nothing about the noted iLO problem thats been posted on here for several systems when questioned about it so either HP dont know about this or they do and haven't passed it on.

So I want to know, and im sure this guy that asked a year ago about this would like an answer too, what is causing this and how can we stop it happening again or what caused it to start happening, I guess we have around 75-100 ML110's around the UK and I guess im a little jumpy, if this is going to start happening on all of them.
Marcos David
Occasional Contributor

Re: Proliant ML110 G4 serial port problem

Hi,
glad to see I wasn't the only one with this problem....
Recently we acquired a new machine, same model (ML110 G4) and we found this problem is fixed.

So, I supposed the problem has been fixed in newer versions...

You should probably complain to HP since it is most likely a defect in the computers motherboard (based on the solution by the HP engineer...)