ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant Microserver Gen8 cannot boot from HDD

jonteohr
Occasional Advisor

Proliant Microserver Gen8 cannot boot from HDD

Hello, I just got my first HP server home!

I've tried installing Ubuntu server and Ubuntu desktop on it and it cannot boot from the HDD when the setup is installed.

I've disabled the raid-controller in BIOS so the SATA mode is set to AHCI.

What it tells me when trying to boot from HDD: Non System disk or disk error.

I have two HDD's in the server: Toshiba 500GB 7200rpm 32mb

Anyone how to solve this? I cannot manage to fix it and I'm really excited to start using linux on it...

7 REPLIES
Jimmy Vance
HPE Pro

Re: Proliant Microserver Gen8 cannot boot from HDD

If the B140i has been disable and the controller is in SATA AHCI mode, the OS should just install and boot.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
jonteohr
Occasional Advisor

Re: Proliant Microserver Gen8 cannot boot from HDD

I have the B120i. And I know it should but it won't and I'm really starting to wonder what the issue might be..

There's no issue booting from any USB drive for setups etc.

My steps of enabling AHCI:

  1. F9 on system startup
  2. System options
  3. SATA Controller Options
  4. Embedded SATA Configuration
  5. Enable SATA AHCI Support

Is there anything else I need to do?

Also: Since I have two drives, I think it's weird that I only can see one HDD in the Standard Boot Order. May this be something that's causing the issue?

 

The sata controller has IRQ set to 7, not sure if it makes any difference

jonteohr
Occasional Advisor

Re: Proliant Microserver Gen8 cannot boot from HDD

My HDD's are plugged in the HDD slots on the front. Are these maybe just for extra drives?

Jimmy Vance
HPE Pro

Re: Proliant Microserver Gen8 cannot boot from HDD

Sorry, I meant B120i, but the way to disable is the same.  The drives should show up as /dev/sda through /dev/sdd if you populate all four slots. The only thing you need to watch for is where the installer is putting the boot loader. if your booting from USBkey, the installer may see it as /dev/sda and install the boot loader there insead of on the first disk which the installer may see as /dev/sdb

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
jonteohr
Occasional Advisor

Re: Proliant Microserver Gen8 cannot boot from HDD

Jimmy Vance wrote:

Sorry, I meant B120i, but the way to disable is the same.  The drives should show up as /dev/sda through /dev/sdd if you populate all four slots. The only thing you need to watch for is where the installer is putting the boot loader. if your booting from USBkey, the installer may see it as /dev/sda and install the boot loader there insead of on the first disk which the installer may see as /dev/sdb

 

 


That's quite interesting! But when I installed, it only found two drives and it even called them by their names: Toshiba. I cannot see any drive names in BIOS. Atleast not in the boot order section. There all I can see is Hard drive (C:) and the usb drive seems to have the same letter assigned to it.

Another suspicion of mine is that I cannot do anything in Intelligent Provisioning. It's just frozen and I cannot click anything on the "Set preferences" page. It says System Boot Mode is set to UEFI boot mode, which I doubt it's supposed to be. I want to change it but I can't since the page is just frozen when I load it on the server.

jonteohr
Occasional Advisor

Re: Proliant Microserver Gen8 cannot boot from HDD

Every time I try booting from my HDD now it just says:

Attempting to boot from Hard Drive (C:)
Attempting to boot from NIC

No idea why it switches to NIC immediately..

jonteohr
Occasional Advisor

Re: Proliant Microserver Gen8 cannot boot from HDD

Issue seems to be solved..? I swapped the positions of my two drives and now it seems to work fine. Wow am I a beginner or what