Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant N36L microserver, WOL (wake-on-lan) not working?

VilleQ
Occasional Visitor

Proliant N36L microserver, WOL (wake-on-lan) not working?

 

Has anyone been able to wake up the server with WOL message? 

I've checked it's enabled in the BIOS, and i can see the network card LED blinking for traffic. 

When i send multiple WOL messages the LED activity clearly increases, so the motherboard should see the message, but nothing happens. 

 

It may be due the fact i'm running OpenSolaris Nexenta and it doesn't support the motherboard's ACPI completely, so it might send it down to wrong power level at powerdown (S2 i guess) . Is there a workaround? 

 

 

 

12 REPLIES
Linker3000
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

Yes, I have tested this using a Windows-based WOL tool and it worked first time.

VilleQ
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

Oh, yeah,  The WOL message has been sent from windows7 and also debian linux - neither wake up the N36L.

 

I do have another server with asus motherboard which does start up with the WOL message.

Andrew Webber
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

Hi,

 

Did you get this working? I have one of these servers running FreeBSD (well FreeNAS) and i can't get it to power on even though the BIOS is set correctly. I have a Windows PC that i can happily power up when i want even from work, so i don't think i have done something wrong in terms of actaul WOL setup.

 

FreeBSD 7.3 seems to not have WOL support for the NIC card, but i thought that just for powering on the hardware via WOL that this would be ok.

 

Drew

VilleQ
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

No, I did not find a WOL-based solution for this. My understanding is that the operating system network driver is responsible for turning the WOL listening on at shutdown. openSolaris driver for N36L NIC lacks the ability, and so i guess, many other *nix family OSs. 

 

In this case, i fiddled a bit with electronics - bought a USB controlled electronic relay, which is connected directly to the power button of N36L. A second computer (which is always on) can now turn on the power via USB command.. :smileyhappy:

 

Andrew Webber
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

Ahh ok i did suspect that. Nice solution, but i don't have another PC that is on lol.  I will see if i can find some better drivers for the inbuilt card.

 

Out of interest where did you get the USB relay?

 

Cheers

Drew

VilleQ
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

 

The relay is this one:

 

http://www.sigma-shop.com/product/7/usb-relay-controller-one-channel.html

 

simple and easy. 

 

Andrew Webber
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

Thanks :)
HousesP
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

I've struggled and failed to get WOL working on Ubuntu (10.04.* LTS + Natty). Upgrading the BIOS made no odds.

 

FYI A fresh install of CentOS 6.0 and it works out of the box for me. (running etherwake, not that it should matter).

 

Very happy.

Netmetrixltd
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

Guys, not for nothin' here but WOL is kind of dead now these days.

It's always been a pain and there are two formats and two types of magic packets.

Plus it seems with this poster there is now an OS dependency revealed...

 

I do this:

Buy this item

http://www.apc.com/products/family/?id=70

 

If that's too robust for your needs they have smaller versions for less money.

 

Then plug all of your systems into it.

 

Configure all of your server's BIOS and Desktop BIOS for "ALWAYS ON" for the "after power failure" setting.

This is something that is BIOS only and not dependant on any NIC state after shutdown.

 

Then put the APC on an outward facing port. (SSH if you are paranoid)

and web into it remotely and turn on and off each individual outlet as needed.

 

 

 

mudd12
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

On Linux you can use 

sudo ethtool -s eth0 msglvl wol on

 to enable WoL. You'll have to do this again on reboot so better put it in a startup script. On Ubuntu ethtool is in a package of the same name. You can also use this tool to query the WoL capabilities of your hardware.

sudo ethtool eth0 | grep Wake-on

 The letter codes are explained in the manpage:

p Wake on PHY activity
u Wake on unicast messages
m Wake on multicast messages
b Wake on broadcast messages
a Wake on ARP
g Wake on MagicPacket™
s Enable SecureOn™ password for MagicPacket™
d Disable (wake on nothing). This option clears all previous options.

 

The N36L NIC only supports 'g', i.e. MagicPacket. Works well for me in any case, as long as I enable it with the command line above.

 

mudd12
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

Maybe for the sake of completeness, it might be that you have to change the line in /etc/init.d/halt that says "NETDOWN=yes" to "NETDOWN=no" to disable the shutdown of the network devices on poweroff. It's not necessary for me though.

ojobson
Occasional Visitor

Re: Proliant N36L microserver, WOL (wake-on-lan) not working?

I'm running ESXI 5.1 and if I shutdown using the vSphere client then the machine will respond to WOL packets. However, if I use the shell and the command;

 

esxcli system shutdown poweroff -d 10 -r test

 

Then after it powers down the machine won't respond to WOL packets.

 

Any ideas?