ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Proliant Support Pack fails with RHEL4 Update 5

 
Occasional Advisor

Proliant Support Pack fails with RHEL4 Update 5

We upgraded several Proliant servers from Redhat RHEL4 Update 4 to Update 5. After the upgrade we reinstalled the Proliant Support Pack (PSP) 7.70 by rerunning the install770.sh script.
We had to reinstall the PSP net-snmp and net-snmp-libs RPMs because those were overwritten by the RHEL upgrade and we were getting a lot of syslog errors:
May 7 16:11:07 serv309 snmpd: Connection from - 127.0.0.1
May 7 16:11:07 serv309 snmpd: transport socket = 15
But even after this and a reboot, the System Management Homepage (SMH) is no longer working !
There are no agents available in SMH.

Question: How does one make PSP work with RHEL4 Update 5 ? We do not dare to upgrade our remaining servers because of this issue.
3 REPLIES 3
Occasional Advisor

Re: Proliant Support Pack fails with RHEL4 Update 5

Now that PSP 7.80 has become available, I installed the new PSP on RHEL4 Update 5. This made the PSP System Management Homepage work correctly for a few minutes with storage agents etc., but then I ran the "up2date -u":
The up2date replaces the PSP net-snmp and net-snmp-libs by Redhat's own RPMs, and this
completely breaks PSP. I have not found any workaround for fixing PSP when this has happened.
HP: Please ensure that PSP can coexist with RHEL4 Update 5.
Occasional Advisor

Re: Proliant Support Pack fails with RHEL4 Update 5

I wish I saw your post earlier today, spent most of my morning pulling my newly installed server to pieces trying to figure out why PSP that normally works wont run. And why I'm getting all these annoying snmpd entries in my logs.

Anyway HP will have to have a chat to RH and come to some agreement to fix the snmpd issue it's going to be a nightmare for me to admin my boxes if I have to force install hp-snmp over rh-snmp everytime there is an update.

Anyway my 2c worth.
Occasional Advisor

Re: Proliant Support Pack fails with RHEL4 Update 5

I have a partial workaround for the broken PSP installation:

1) You *must not* have the latest Redhat net-snmp* RPMs installed.
2) Using "up2date --configure" you must add exceptions for the package pattern "net-snmp*".
3) Install PSP 7.80 as usual.

At this point you can run up2date without ruining the PSP functionality.
If you ever get the Redhat net-snmp* RPMs installed, the PSP agents will stop working !!