ProLiant Servers - Netservers

RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

 
neopipes
Occasional Contributor

RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

Hallo Leute,

Ich habe diesen Thread hier auch im englischen Board gestellt, nur um sicher zu gehen den maximalen Input zu bekommen.

wie der Titel sagt ich kämpfe gerade mit meinen neu erworbenen Produkten, dem HPE Microserver Gen10 und dem HPE Smartarray e208i-p.

Ich will einen RAID verbund "builden". Das ist mein Ziel.

Ich kannte es so dass, bei DELL oder IBM Servern der Raid controller eine Message ausgegeben hat "Press F8 for Raid configuration utility" bei alten Smartarray controllern war es glaube ich STRG + i oder STRG + 3.

Ich bekomme gar keine Aufforderung.

Das habe ich probiert:

UEFI System Utilities - So wie ich verstehe das Herz meiner Konfigurationsmöglichkeiten an meinem Microserver, also Boot Option umgestellt auf UEFI und leider beim POST nur die Std. Meldung "F11" for Boot Menu und "DEL" for BIOS Setup, kein Aufforderung für "F9" (UEFI Sys Util)

ORCA - Keine Aufforderung, F8 drücken bringt nichts

HPACU (offline) - leider wird mein Smartarray nicht unterstützt, habe es trotzdem versucht ohne Ergebnis

HPSUM (offline) - Dacht mir vielleicht bringt es was die zu installieren für aktuelle Versionen etc. aber er bring mir einen fehler bei der identifizierung der Nodes (Baselines sind ok).

Ich bin wirklich mit meinem Wissen am Ende.

Was kann ich tun? Wo ist mein Fehler?

Welche Informationen kann ich euch noch zusätzlich geben das ihr es einfacher habt mir bei meinem Problem zu helfen?

Ich bin für jede Hilfe, jeden Denkanstoß, jede Information dankbar!

Grüße

Benjamin

9 REPLIES 9
Torsten.
Acclaimed Contributor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

How to create a RAID?

From the user guide:

 

Marvell Storage Utility
The Marvell Storage Utility is a browser-based configuration and management utility for the embedded Marvell storage controller
. Use this utility to create and manage RAID virtual disks and arrays using the drives
connected to the embedded storage controller
.
For more information, see the Marvell Storage Utility User Manual for 88SE9230 and 88SE9220
included in the SATA management tool package for the server. To download this package, go to the Hewlett Packard Enterprise Support Center website (http://www.hpe.com/support/hpesc
). Under
Select your HPE product
,
enter the product name or number
, and then click
Go
 
 
 
.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
neopipes
Occasional Contributor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

Hey thanks for the reply.
Sadly this guide is for the embedded storage controller.

I use HPE Smartarray e208i-p, which is a pci-x storage controller card.

Do you have any advice on how to proceed with that particular card?

Did i post in the wrong forum maybe?

 

Cheers

Jimmy Vance
Honored Contributor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p


@neopipeswrote:

Hi Guys,

I have put this thread here in the English board, just to be sure to get the maximum input.

As the title says, I am currently fighting with my newly acquired products, the HPE Microserver Gen10 and the HPE Smartarray e208i-p.

I want to build a RAID. That is my goal.

I knew it so that, at DELL or IBM servers the Raid controller has issued a message "Press F8 for RAID configuration utility" with old Smartarray controllern I think it was Ctrl + i or Ctrl + 3.

I do not get a call.

I tried that:

UEFI System Utilities - As I understand the heart of my configuration options on my microserver, so Boot Option switched to UEFI and unfortunately only the hour message "F11" for Boot Menu and "DEL" for BIOS Setup, no prompt for "F9 "(UEFI Sys Util)

ORCA - No prompt to press F8 does not help

HPACU (offline) - unfortunately my smart array is not supported, I tried it anyway without result

HPSUM (offline) - I think maybe it brings what the install for current versions, etc. but he bring me a mistake in the identification of the nodes (baselines are ok).

I am really finished with my knowledge.

What can I do? Where is my mistake?

What information can I give you additionally that you have easier to help me with my problem?

I am grateful for any help, any food for thought, any information!

greetings

Benjamin


The embeded controller uses the Marvell storage utility as Torsten has shown.

The MicroServer Gen 10 does not use a standard ProLiant ROM, so the normal RBSU settings along with storage utilities are not available during POST.  To configure the e208 controller you will need to either download the SPP or the Offline version of HPE SSA

Offline HPE Smart Storage Administrator (HPE SSA)
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_025517e238c54339aa319d7c31#tab1

No support by private messages. Please ask the forum! 
Nekobix
New Member

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

Hi,

did you manage to use the controller? I have the same issue, what I found out is:

1) The controller seems to work only in Legacy mode, does not seem compatible with the Microserver gen10 BIOS
(in fact it's not detected)

2) In legacy mode, the controller is recognized and you will see the physical disks will show up

3) Still in legacy mode, you can use the HP SSA, but not the Standalone Offline one. You need to use the one included in the latest SSP. When you boot the SSP, chose manual mode and then on the main screen you can pick to update the system, use the Storage Administrator or Perform system tests. Pick the SSA and there you can prepare your RAID-5

4) It will take two or three reboots to be able to start the SSP, it seems having trouble picking up the USB. If this happens use the F11 for boot selection

5) Doing like this, i've managed to install windows, but it seems we are limited to use MBR. Converting the disk to GPT and booting with UEFI, will break everything.

The gen10 is a bit step down from the gen8 where you could use intelligent provisioning. This machine is not going anywhere...they took away the iLO as well....so far it's a great disappointment.

If you found a way to use UEFI, with the additional controller, let me know!

Regards

Nekobix

DanielL1
Advisor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

@Nekobix, you just made my day. I upgraded the controller to 1.65 and thought it was done, because it didn't respond in UEFI anymore: https://community.hpe.com/t5/ProLiant-Servers-Netservers/Cannot-configure-SmartArray-e208I-P-SR-GEN10-on-HP-MicroServer/td-p/7004214 I didn't try legacy boot as I thought it was done like with the balanced power mode issue described in that thread too.

However 1.65 works with Legacy boot! I've just downgraded to 1.60 in Legacy mode and can now use UEFI with controller version 1.60 and Server Firmware version ZA10A360 again!

SplatMan
Advisor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

I would love to do the same. I have this server+controller and it's been nothing but a PITA. But I can't replace it so I am looking to downgrade the firmware to 1.60. Sadly that version is not available for download any more.

Any tips on how to get hold of 1.60?

SplatMan
Advisor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p


@SplatMan wrote:

I would love to do the same. I have this server+controller and it's been nothing but a PITA. But I can't replace it so I am looking to downgrade the firmware to 1.60. Sadly that version is not available for download any more.

Any tips on how to get hold of 1.60?


The absence seems to be due to an error in the support portal when using Chrome. If you dont get the "Revision history" tab, or if no content is being loaded into the download page at all, try switching to a different browser.

The older 1.60 firmware is avilable for download through the "Revision history" tab.

SplatMan
Advisor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

*** UPDATE ***

(This post left here for honesty and clarity - please see UPDATE 2 post below)

On dec. 20. 2019 a bunch of new updates were issued to the Gen10 Micro Server. Sadly no updated System ROM (so that's still ZA10A360 as of this writing), but there was an updated firmware for the SmartArray controller to v 2.62.

I tested this update so you didn't have to. Results:

1.) The controller still can't be configured from the UEFI menu system. The existing error where the user is simply returned to the first UEFI menu screen is still present, making it impossible to configure any aspects of the arrays/disks without booting a full operating system.

2.) The controller still doesn't work when the system is set to UEFI mode. The only way to use the controller or any drives attached is to force Legacy mode on. It also doesn't work with CSM, even though one has to wonder why (the option ROM should be loaded with CSM enabled but it doesn't).

If you need UEFI mode and you applied the new version, you may have to downgrade to v. 1.60 which is the highest version people have working with UEFI mode. Be aware that several issues listed as fixed in later versions could be affecting you, so make sure you understand the consequences of running on that version. Also be aware that there is no guarantee that 1.60 will work in UEFI mode. My setup - for reasons unknown - doesn't.

Note that booting an OS from a USB Key while in UEFI mode also doesn't work. The controller won't be initialised, so it won't be visible to you.

If you already have version 1.60 on it, and you're booting in UEFI mode then DO NOT UPGRADE THE FIRMWARE. If you do, for example to v 2.62 as "recommended" by HPE, the system will stop working and you will be unable to boot untill you downgrade the controller firmware. If at all.

** SEE UPDATE 2 BELOW FOR MOST RECENT INFORMATION **

Thanks HP ... (no, not really).

SplatMan
Advisor

Re: RAID erstellen HPE Microserver Gen10 + HPE Smartarray e208i-p

** UPDATE 2 **

I was in fact able to configure the SmartArray controller to work with UEFI mode. It took a lot of trial and error, and since the server's POST process is really slow, it's something that requires patience.

To be clear: You can get the controller working in UEFI mode with latest firmware, but there are a lot of pitfalls.

Here are the things to consider during installation (use at your own risk):

1.) After updating server+controller to most recent firmware versions you still can't configure the arrays from within the UEFI menu system, even though this is clearly something that was intended. The menu system will just throw you back at page 1 of the menu system. So forget about configuring anything from here.

2.) The controller can not be configured in UEFI mode using HPE SSP software. It will start booting but eventually halt at a white screen. I am told some people have had luck configuring the controller using command line options through Linux, but don't expect to configure the controller while the server is in UEFI mode.

3.) If you install a full OS (for example Windows 10 or Linux) while the system is in Legacy mode then you may be able to configure it. If your Linux-fu is not strong, then I suggest using Windows 10 and the HPE SSA software package. To achieve this, attach a SATA device to the internal port and install your OS of choice on it. You will then have a permanent boot option in Legacy mode. From here you can configure the controller.

4.) If you experience problems configuring the controller, you may need to reset it's configuration completely. There is an option in the software to do that. In SSA it's a button called "Clear Configuration". Reboot when you're done. Note that this should not break your arrays, since the configurations of arrays is written directly to the disks. Having said that, as I noted above, I take no responsibility for your use of these tips/guides.

5.) With the system in legacy mode and the ability to boot, and having cleared the SmartArray controller config, configure the array(s) you need. If you plan to boot from any devices attached to the controller, make sure to enable them as boot devices in the controller config software. In SSA this is an option called "Set bootable Logical Drive/Volumes".

6.) When you're done with these steps, remove the legacy SATA device and set the server to UEFI mode. I suggest powering it off completely after reverting to UEFI mode.

7.) You may now use the SmartArray controller in UEFI mode.

As mentioned in other posts: DO NOT CHANGE THE POWER SETTINGS TO "BALANCED". Doing so may brick your controller and leave you unable to use it. If you already did this, contact HPE to start an RMA case.

I wish you the best of luck.