ProLiant Servers - Netservers

RAID0 and drive fails intermittently. DIfferent id when is online

 
ndavies
Occasional Advisor

RAID0 and drive fails intermittently. DIfferent id when is online

I have a RAID 0 setup with 4 disks on a HP Netserver. Disk "A00 - 02" keeps failing in the array, but sometimes I can get it to get recognised and bring online in the RAID config. The problem is it shows as a different number "A01 - 00"...it should be "A00 - 02".

My question is, if I reconfigure the array, i.e wipe the config and then build the array and logical drive with the disks in the same order will the data survive this process?

Any help would be greatly appreciated as I really need the data from these drives due to a backup failure.

Nigel
2 REPLIES 2
ndavies
Occasional Advisor

Re: RAID0 and drive fails intermittently. DIfferent id when is online

Ok. maybe an easier question.

The drive that keeps failing sporadically in bay 3 runs a lot reliably in bay 5 on the server, hardly ever shows a failure in this bay.

Can I rebuild the array and mark the drive in the same order even though it is in a different bay?

Nigel
ndavies
Occasional Advisor

Re: RAID0 and drive fails intermittently. DIfferent id when is online

Ok. Sheer desperation has caused me to just go for it.

Cleared the array config, red light goes out on suspected hard drive straight away .... yipee

Rebuilt array with same stripe size and it booted up. Not usually one to take the plunge, but I was desperate!!!

Hope this helps any one else in the future.

Nigel