ProLiant Servers - Netservers

RHEL4 U1 EM64T and hpasm problem

 
CA1304342
New Member

RHEL4 U1 EM64T and hpasm problem

It's a fresh OS installation on DL380G4. When I install hpasm (x86_64) 7.3.0c-67 (the latest one as on July 19) It gives me error:
libgcc_s.so.1 must be installed for pthread_cancel to work

a locate will show:
# locate libgcc_s.so.1
/lib64/libgcc_s.so.1

How can I fix it? Does the hpasm supposely support RHEL 4.0 U1 EM64T version?

Thx.

WIlson
5 REPLIES 5
CA1090837
New Member

Re: RHEL4 U1 EM64T and hpasm problem

I am also having this problem on a DL385.

With both 7.3.0b-63 and 7.3.0c-67
Oleg Koroz
Honored Contributor
Rene Simons
New Member

Re: RHEL4 U1 EM64T and hpasm problem

Same problem here, DL380G4 with EM64T CPU's
RHEL3AS U5, tried PSP 7.30 and PSP 7.40, but both failed to install compat-libstdc++-7.3-2.96.128.i386.rpm so no go.....

Manual install of compat-libstdc++-7.3-2.96.128.i386.rpm fails dependencies:
libgcc_s.so.1 (GLIB2.0)

I would think this would come up at basic testing:
- new machine
- install RHEL3U5
- deploy PSP
-> error

Seems like it is looking for RH7 (GLIB2.0) stuff which is removed in PSP 7.40 ???

Any Work-arounds would be appreciated
Rene Simons
New Member

Re: RHEL4 U1 EM64T and hpasm problem

Found the answer myself, like to share it.

It seems that not everything is 64-bit when you install RHEL for EM64T.

In the installation there is a new package called 32-bit support.

Install that and the problem disapears....

at least for me it did..

Rene
CA1304342
New Member

Re: RHEL4 U1 EM64T and hpasm problem

Actually...I fixed it long time ago already...just too lazy to post the solution...in the past, I just install the individual hpasm, hprsm, hpsmh...however, one time, I just install the OS and set up the psp suite...and everything just works fine..no worries.