ProLiant Servers - Netservers

TC4100 Netserver Dual CPU

 
Adam Collyer
New Member

TC4100 Netserver Dual CPU

Hi,

I have recently replaced the CPUs on my TC4100 Netserver - it's now running on dual 1GHz PIIIs (both stepping code SL52R). However when I power on, I get a "missing CPU microcode" error. After a bit of googling, I have come to an assumption that HP has implemented a "whitelist" of CPU stepping codes that are allowed to be installed (namely ones bought directly from HP?)...

The server works perfectly once I press F1 to continue, it's just I get the error on every boot... I have had issues such as this in the past with other hardware, and there has usually been an unofficial bios patch to prevent errors such as this...

Would anyone happen to know of an official/unofficial patch for the BIOS of this server to allow all CPU stepping codes? It's not a massive bother for me as the server is onsite so restarting isn't a massive inconvenience, but it would be nice to remove the error nonetheless :)

Thanks in advance,
Adam Collyer
2 REPLIES 2
Sean T. Craig
Honored Contributor

Re: TC4100 Netserver Dual CPU

Hi Adam,

Have you tried reflashing the BIOS yet? Try creating an update set from the following download:
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=78192&prodNameId=78194&swEnvOID=54&swLang=13&mode=2&taskId=135&swItem=ns-13699-1
After you flash the BIOS, clear the CMOS and load default values. There are 2 ways to clear the CMOS on the TC4100:

1. Locate the DIP Switch pack on the system board and move switch 4 to the ON position. Power up the server and wait for the message instructing you to move the switch back. Power down and turn switch 4 OFF.

2. Press during POST to access the Advanced CMOS Setup (as opposed to the normal setup). Go to the "Exit" tab and select "Clear System Configuration and Exit Setup".

Once this is done, go into the CMOS with and load default values by pressing . Save and exit.

Try that and let us know if it has any effect.

Good Luck,

Sean T. Craig Sr. C.E.T., M.C.P.

I am King...of my apartment.
Adam Collyer [Work]
New Member

Re: TC4100 Netserver Dual CPU

Hi Sean, thanks for your reply.

I have flashed the BIOS, although I hadn't modified the DIP switch and booted, so I tried it again - unfortunately it hasn't many any difference :(

The exact error code is:

0B01-0A : Missing Microcode Update data block for Microprocessor

Like I said, I think it's something hardcoded in the BIOS as the system fuctions perfectly otherwise...


Cheers,
Adam