ProLiant Servers - Netservers
cancel
Showing results for 
Search instead for 
Did you mean: 

USB ports not functioning during boot process

ezekielincorr
Occasional Visitor

USB ports not functioning during boot process

I have a microserver gen8 and successfully created a USB install of FreeNAS (from another USB stick, on the same system) but have had a long frustrating time trying to get it to boot. What is particularly confusing is that I couldn't get it to boot for a long time, then for a while, the USB keyboard stopped working, then having done nothing but move the USB pen and keyboard around from port to port, and experimenting with plugging them in after the system POST, it suddenly successfully booted. I tried rebooting again and it worked, without any intervention from me.  Then I swapped a hard drive - and it stopped working again - I have tried putting back that initial hard drive, recreating exactly, the hardware configuaration that allowed a successful boot and it no longer boots although now, the USB keyboard seems to work (ie. I can access the setup utility or boot menu, which I couldn't for a while). If I access the boot menu and press '3' to boot from USB drive key, this fails and the system boots from the HD.

I tried updating the firmware at one point via iLo (from the 2016 version to the 2018 version, but this repeatedly failed. (yes, I checked the sha256 sum)

In the 'setup Utility' the USB DriveKey is the number 1 boot priority

USB Boot Support is Enabled

USB Drive Key Enumeration is enabled

Flash Media Boot Sequence is 'Internal Drivekeys First'

(The HD has XCP-ng on it and can see the USB drive with 'lsusb')

Any suggestions as to what on earth is going on and how to fix it would be wonderful!

Update: I just unplugged the machine to put the case back on, and then it turned it back on and it correctly booted from USB and rebooted multiple times into FreeNAS. I decided to try shutting the machine down, and unplugging all of the cables and then plugging them back in in the same ports and once again, it no longer boots from USB, falling back onto booting from the HD.

2 REPLIES
Jimmy Vance
HPE Pro

Re: USB ports not functioning during boot process

The USB 3.0 ports do not function until after the OS is booted, the USB 2.0 ports work during POST..  There are two 2.0 ports on the front and two 2.0 ports on the rear of the system




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
ezekielincorr
Occasional Visitor

Re: USB ports not functioning during boot process

Thanks for your suggestion, I have tried *every* USB port on the system including the ones on the front, back and the internal one and had really inconsistent results. As I note, the exact same hardware configuration will do different things, from boot to boot. I have managed to get consistent booting using a FreeNAS install on a uSD card in the internal uSD slot but I don't consider this to be a long-term solution given the long-term liklihood of failure of an sd card.

I am using USB 3.0 drives, but I doubt that's relevant?

It looks like a number of other folk are having the same issue https://forums.freenas.org/index.php?threads/hp-proliant-ms-gen8-g1610t-wont-boot-usb-with-freenas.49268/