ProLiant Servers - Netservers

how do i retreive my data?

New Member

how do i retreive my data?

i have an ML330 proliant(G3) server. the machine had a 240 GB partition on RAID 0 (2x120GB drives. According to a colleague, he tries to start the machine but he noticed that the fan went on for so long, so he powered the machine off. after cooling for some time the machine tried to boot, but now had a corrupt windows 2000 system file.
i tried to use a repair diskette and also tried to set it up with a bootable win 2000 server CD, using the raid controller software in the smartstart CD. I did not succeed because it gave a blue screen.
i tried to use the smart start CD to see if i can setup win 2000 on a fresh parttion and then connect my 240gb partition. I keep getting the "240gb partition if Offline". if i have to initialize the array, i may loose data that is key to me.
What do i do so that i can keep my data intact without initializing or formatting
Honored Contributor

Re: how do i retreive my data?


It sounds as if the RAID controller has failed. Does the controller isse any error messages or have you run diagnostics to determine if the controller is working correctly?

If the controller has indeed failed, "do nothing" until it is replaced. After the controller is replaced, the drives (which contain the array signature) will init and you should be up and running.
"Now is the only thing that's real!"
New Member

Re: how do i retreive my data?

Thanks for your response.
I tried setting up the OS on a fresh 120gb partition (RAID 0) and i noticed that using the RSBU configuration utility (F8 during bootup) the drive is degraded. After windows 2000 server setup, i added ny 240GB Partition, i started the server and used F8 (raid configuration utility), i noticed that the three drives were online, but with an auto config RAID 0+1 setup, two 120gb were online and one 120gb was degraded.
using the HP system management,when win 2000 server was loaded it says the CSB-6 Ultra ATA - 100 IDE raid contoller on system board is degraded.
Could this be as a result of the drives not being initialized?
Looking the HP system management i can see that are no problems with the disks on the primary channel (120gb attached)
secondary channel (2x120gb attached)
but on the ATA logical drives i find the following
logical drive 4, status is ok RAID 0, 114471 MB, stripe size is 117218752kb

logical drive 5, status is degraded, RAID 1, 114471 MB, stripe size is 0 kb

logical drive 6, status is ok RAID 0, 114471 MB, stripe size is 117218752kb

If all of this confirms that the IDE raid contoller on the system board is faulty, what are my options? PCI Hardware controller? Would i require the system board controller to work to normally to be able to retrieve my data?


please nb
i also noticed the RaidMonitor icon says the "the system has failed/disconnected drives". this icon should be green but has gone red!!!