ProLiant Servers - Netservers

hpasm on rhel 5

 
the Crazy
New Member

hpasm on rhel 5

Hi,
I have i problem on a prolian DL360 G5 whith rhel5
I try to install hpasmcli whith this rpm:
hpasm-7.8.0-88.rhel5.i386.rpm
It install the package, but on configuration give me this warning:

==============================================================================
The selinux boolean 'allow_ypbind' was enabled.
==============================================================================
==============================================================================
Text relocation was allowed for libcpqci.s0.1.
==============================================================================
==============================================================================
NOTE: selinux configuration in file_contexts was amended.
==============================================================================
==============================================================================
NOTE: Your SNMP stack can load the 32-bit hp ProLiant Management Extension.
Problems may result from using your distribution's SNMP stack.
See hp Documentation (HOWTO, agent manual) for more details.
==============================================================================

and when I try to start hpasm this say to me:
/etc/init.d/hpasm start
sed: can't read /etc/init.d/ipmi: No such file or directory
Using standard Linux IPMI device driver and hpasm-lite
Starting Proliant Standard IPMI based System Health Monismlited):
Starting Foundation Agents (cmafdtn):

Starting Server Agents (cmasvr):

Starting Storage Agents (cmastor):

hpasm: Server Management is enabled

----------------

And the file /etc/init.d/ipmi don't exist.
I hope this problem is generated by selinux.
Someone have some solution for this?
Regards

1 REPLY 1
Chris Rosan
Valued Contributor

Re: hpasm on rhel 5

My solution=turn off selinux.

More:

Is your server facing the public internet? If not, unless you have a lot of highly skilled staff that you wouldn't trust with your coffee cup, i don't see the need for it.

You can set it to "warn" rather than "block". This way you can ascertain if it will cause problems on your systems. I did this with my first RHEL4 box that has it, and it "warned" me so much i had to turn the warning off.

Unless you're defence CIA or MAJOR finance (in which case i don't know that you'd be on here) i don't see a need for it.

From memory you can turn it off through "system-config-security-level" or something similar. That was on RHEL4 though, i'm not sure of RH5, haven't used it yet but it can't be that hard.