Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II)
cancel
Showing results for 
Search instead for 
Did you mean: 

Backing up iLO configs from Blade enclosure?

Ben Short
Frequent Advisor

Backing up iLO configs from Blade enclosure?

Hi All,

 

I am wanting to back up the configuration of the iLO interfaces in my blade servers by dumping the configuration to file. All the blades are running VMware ESXi, which means that the 'hponcfg /w' command is not available to me.

 

the cpqlocfg command does not appear to have any option to dump the config, so I was wondering if there is any way to dump configs out of BL series servers remotely?

 

Thanks

 

4 REPLIES
Jimmy Vance
HPE Pro

Re: Backing up iLO configs from Blade enclosure?

A couple of ways to accomplish this.

 

You can run HPONCFG when logged into the OA via SSH and capture the output to a file from your terminal program., or you can grab the iLO XML examples for use with hponcfg, cpqlocfg and locfg.pl

 

Using the OA CLI

http://h30507.www3.hp.com/t5/Eye-on-Blades-Blog-Trends-in/Blade-Hacks-CLI-Tips-and-Tricks/ba-p/38528#.U-uAeLEo5aQ

 

iLO XML examples (look at hponcfgcap.xml)

 

http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdDetails/?lang=en&cc=us&swItem=MTX_e8dbfeb5c88c4689a2958de054

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Ben Short
Frequent Advisor

Re: Backing up iLO configs from Blade enclosure?

Hi Jimmy,

 

Well, got part of the way there. I was obviously blind and missed the hponcgcap.xml script when I looked through things yesterday. I also needed to get the latest version of the sample scripts, as the XML has changed from my copy :)

 

Got part way there, dumped out the config. However the XML transform appears to error out. firstly with

 

PS H:\Powershell\ILOScripts> .\msxsl.exe samplelog.xml hponcfg_reformat.xsl /o sample-new.xml

Error occurred while parsing document.

Code:   0xc00ce556
URL:    file:///H:/Powershell/ILOScripts/samplelog.xml
Line:   1
Column: 1
Invalid at the top level of the document.

So I removed Line one of the log, which is a text saying what the IP address off the server is. I then get:

 

Error occurred while parsing document.

Code:   0xc00ce557
URL:    file:///H:/Powershell/ILOScripts/samplelog.xml
Line:   8
Column: 3
Invalid xml declaration.

 

First 8 Lines look like:

 

<?xml version="1.0"?>
<RIBCL VERSION="2.23">
<RESPONSE
    STATUS="0x0000"
    MESSAGE='No error'
     />
</RIBCL>
<?xml version="1.0"?>

 

So I'm not really sure whats going on here.

 

 

 

 

Ben Short
Frequent Advisor

Re: Backing up iLO configs from Blade enclosure?

Further investigation has found that cpqlocfg creates a significantly different logfile to hponcfg, which is what would be causing the XML transform errors.

 

Currently investigating a workaround, and will update this thread when tested.

Ben Short
Frequent Advisor

Re: Backing up iLO configs from Blade enclosure?

As a way of finalising this thread, I ended up finding hponcfg in /opt/hp/tools on our ESXi installs. All of our ESXi installs use an HP customised image and therefore the tools are already installed.

 

After using hponcfg I used SCP to transfer the config off the server.