Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

Change in server boot behavior from ILO2 1.35 to 1.42

Honored Contributor

Change in server boot behavior from ILO2 1.35 to 1.42

Got a BL460c server with ILO2 firmware 1.35 that when it boots windows
shows the recovery console option>>

Windows Server 2003, Enterprise [EMS enabled]
Microsoft Windows Recovery Console

The top option is highlighted, after about 5 seconds it autoselects the selected option and then boots windows.

If I put firmware 1.42 on it then it does not select an option and sits and waits for the user to select one. This is causing problems with image deployments, as some servers now require manual intervention.

Has it got something to do with WHEA support? Is there a registry key or ILO option to change?
13 REPLIES
Occasional Contributor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

Same for me:
Proliant DL385 G2, Windows 2003 64bit
Honored Contributor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

There are some changes in iLO 2 v1.42 that might come into play. Clipped from the release notes:
http://h18004.www1.hp.com/support/files/lights-out/us/revision/9270.html
-> Fixed an issue that could cause possible VSP data loss when displaying to the screen

-> Fixed an issue that could cause a possible hang when installing Windows Server 2003 on a blade a server if a VSP client is not connected

Microsoft Windows Hardware Error Architecture (WHEA)

iLO2 supports the 'Error Record Persistence' feature of the WHEA architecture.

This allows the Windows Operating System to save and retrieve hardware error records to/from battery-backed non-volatile storage (NVRAM).


I do not think that WHEA is related to this. It is more likely virtual serial port via SPCR:
http://technet2.microsoft.com/windowsserver/en/library/5d7c7670-fad8-4936-821a-0999292e435d1033.mspx?mfr=true

Have you checked boot.ini (bootcfg.exe) to see if there is a default OS timeout established?
You you have an open connection to virtual serial / remote serial console when the OS boots?

This behavior sounds like what happens when a menu sees keystroke activity and cancels the timeout default behavior.
Occasional Visitor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

I am experiencing this issue as well. Has anyone discovered whether or not there is an option in the BIOS or ILO to change settings so that we can have the system automatically boot into the OS after a set time period?
Honored Contributor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

This is being investigated by the HP iLO team and appears to be related to a firmware change.
Super Advisor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

I can just add in that we are possibly experiencing the same on several blade servers, removing additional entries in boot.ini seem to be a workaround however that is rather tedious work when having multiple servers.
Occasional Visitor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

Either open an ilo2 virtual serial console or Disable EMS console from the BIOS then the problem goes away.
Occasional Advisor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

I received a call from a customer with the exact same issue.

new BL460c and BL465c Blades
when they have windows installed with EMS enabled
and with the recovery console it goes to the
stops there and waits until someone presses enter.

iLO firmware is 1.42.

I advised him to downgrade the firmware to 1.35 and the issue went away, so that is also an option.
Occasional Visitor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

Experiencing the same problem on several BL20pG4 blades. Will HP be releasing a firmware update to fix this?
Honored Contributor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

See
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1185236

So next week (with Xmas & NY?) or possibly in Feb.
Honored Contributor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

iLO2 version 1.43 with the fix for this issue has been released.



__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
Super Advisor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

My SIM server does not seem to be downloading any 1.43 FW for ILO2 for some reason, does anyone happen to have the direct download link on the web ?
Honored Contributor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

To download the latest iLO 2 firmware:

Go here: www.hp.com/go/ilo
Click iLO 2 Advanced
Click Download Software
Click OS
then download the top firmware component.

The page is rearranged, so it looks different than before.
Occasional Visitor

Re: Change in server boot behavior from ILO2 1.35 to 1.42

Deploy Windows and wait for it to complete - Do not open an iLo2 session to view the progress of the deployment. Once the image is deployed succesfully, you can continue viewing ilo2 - hope this helps
//Add this to "OnDomLoad" event