Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

SOLVED
Go to Solution
Occasional Visitor

DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

Hi there

Sorry to ask some real greenhorn questions...

I have a DL 380 G3 and DL 580 G3 which both show the same problem:
The iLO NIC IP address can be pinged, but none of their services are answering. (Connection refused on port 80, 443 etc.). It's probably just a coincident that both iLO card's services have failed nearly on the same day...

What needs to be done? Is it a known problem with a standard solution? Is there a factory reset button somewhere? Can I replace the firmware to potentially make it work again? How?

Thanks for your time. I really appreciate.

-
David
9 REPLIES
Trusted Contributor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

It looks like iLO has crashed. Did you try any firmware flash on those servers? I hope ports are not blocked by firewall.

If you have HPONCFG installed on those servers (available with PSP), you can try to reboot the iLO by applying Mod_Network_Settings XML script. No need to change any values in the script. OR in Windows HPONCFG GUI tool, you have option to reboot iLO.

If feasible, you can remove the power cable from server, leave it for about 30 seconds and then insert the power cable back.

If you have Linux OS on the server, you can try iLO Online flash component (can be downloaded from hp site, with .scexe extension) and flash firmware.

You can check if FTP prompt is open. If yes, then login using username/password as flash/recovery "mput" in binary mode the iLO firmware image.
Honored Contributor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

how did you determine the ilo ip-adress?
is it dhcp or fixed?
did you look it up in dhcp-server or in dns-server?

if dhcp, then the dhcp-address may not match anymore with the dns-entry of the same address.
so when pinging "ilo_nnnnn" you are realy pinging someone-else.
(has to do with "rights" on the registration in; dns workstation can overwrite ilo but ilo cannot overwrite workstation).
disconnect network cable and reconnect to get a new address and update registration in DNS.
if fixed and you access on address, then above does not apply.

if you log in to the "system mangement homepage" of the server, you can acces the "logs" tab from where you may inspect the ILO-log for any hints about the cause.
Occasional Visitor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

Thanks for your suggestions!

The IP of the iLO is static. I have loaded the newest version of the hponcfg utility as the one installed was an old version. I created a backup of the configuration by running "/w backup.xml", then I blanked the XML file so that it only contains open/close tags and have loaded it back again by "/f justtags.xml" - it didn't help. The gui utility creates log and xml files and then crashes with an .Net runtime error message. I shy to touch it again.

FTP service is not started (I think we never had it enabled) or at least it is not answering now.

I think I will try the thing with powering off the computer for 30 seconds when I get a chance and then we'll see...

Thanks everyone!
Honored Contributor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

you can reset the ILO config with the "hponcfg.exe /reset" command instead of a blank xml-file.
Occasional Visitor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

Won't that (/reset switch) wipe my configuration as well?
Occasional Visitor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

It's working again.

Here is what made it work again:
1) Create a file, say network_reset.xml, with the following content:
---------








---------
2) Then run hponcfg /f network_reset.xml.
Firmware Revision = 1.21 Device type = RILOE II Driver name = cpqrib2

Script succeeded

I have uploaded a similar file before, but I did not have the MOD_NETWORK_SETTINGS tag in my file. Also hponcfg did not print the following to the console:



Thanks much! Saved me a lot of time going to the DC. This fixed the issue on both servers. DL 380 and DL580 both G3 generation...
Honored Contributor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

yes, the /reset would have brought the ILO to factory defaults (wipe your config).
but from there you could load it again from your saved xml-file.
good to hear you found a shorter way to do it.

regards,
Pieter
Occasional Advisor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

I am also facing the similar issue with my DL385 G1 servers. I tried both the options mentioned above i.e. xml script and hponcfg.exe /reset but no luck. Still I am unable to open the iLO web interface.

Please help.
Honored Contributor

Re: DL 380 and DL 580 G3 iLO pingable, but web interface unreachable

Try applying the latest iLO firmware update using the Online OS component.

This process resets iLO at the end of the update.