Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

HP Lights-Out Online Configuration Utility won't run.

SOLVED
Go to Solution
Occasional Advisor

HP Lights-Out Online Configuration Utility won't run.

When I try to execute hponcfg_gui.exe using "run-as administrator", I receive two error dialogs and after clicking ok on both, the GUI opens but doesn't show any data.

I have attached a ZIP file contaning pics showing progression of steps for the above, and two TXT files contaning the Windows Error Log data for the two errors listed in the Windows Error Log relating to this.
9 REPLIES
Occasional Advisor

Re: HP Lights-Out Online Configuration Utility won't run.

Sorry, forgot to include OS info.

Running Windows Server 2008 R2.
HPE Pro

Re: HP Lights-Out Online Configuration Utility won't run.

You need the iLO management interface driver to be loaded before hponcfg will function.

This link has the needed drivers for iLO3

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=4154847&prodTypeId=18964&prodSeriesId=4154735&swLang=8&taskId=135&swEnvOID=4064




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Honored Contributor

Re: HP Lights-Out Online Configuration Utility won't run.

Yes,
Sounds like there is no driver to allow the OS talk to iLO.
If my post was helpful please award me Kudos! or Points :)
Occasional Advisor

Re: HP Lights-Out Online Configuration Utility won't run.

Thank you for the quick answer! I apologize for the very delayed response on my part.

This server is a DL580 G5 and does not have iLO3. I did take your advice on installing the driver though. However, since I had run the PSP 8.70 the drivers were up-to-date. Online config util still won't run properly.

Additionally, I can't connect to iLO via web browser, but not sure if this is simply because it's not properly configured or if it is for some other reason.

Also, I am not able to config iLO from the console upon booting the server. The POST message states that "The iLO module is currently unavailable".

Maybe this is an actual hardware problem with the iLO module? I'm wondering if I should open a hardware support case?
Honored Contributor

Re: HP Lights-Out Online Configuration Utility won't run.

iLO2 could be unresponsive.

Can you have somebody go onsite and shut down the server then, remove the power cord for ~10 seconds?

If iLO2 comes back after that then, you need to upgrade iLO2 firmware to version 2.05. This version in particular fixes several bugs that made iLO2 unresponsive in the past.



__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
HPE Pro

Re: HP Lights-Out Online Configuration Utility won't run.

Could be a hardware issue. Have your removed power from the system to reset iLO?



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: HP Lights-Out Online Configuration Utility won't run.

Thanks to both of you for your responses. I will try that later this morning and reply with results.
Occasional Advisor

Re: HP Lights-Out Online Configuration Utility won't run.

That's all it took! The firmware hadn't been updated since iLO was not accessible. Once it was reset, I updated the firmware to 2.05 and life was good!

Online config app works now!

Thanks much for your help.
Occasional Advisor

Re: HP Lights-Out Online Configuration Utility won't run.

Solved per above...
//Add this to "OnDomLoad" event