Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

ILO DDNS Registration

Super Advisor

ILO DDNS Registration

Have several ILOs and upgraded them to 1.82.

DNS servers are pointing to our Active Directory Integrated DNS servers (2003).

I am splitting up the FQDN of the ILO using the hostname in the "ILO Subsystem Name" field and the DNS suffix in the "Domain Name" field.

Now Windows servers can register just fine to these DNS servers but the ILO's can't seem to. Anything I am missing in the configuration? Thanks!
9 REPLIES
Valued Contributor

Re: ILO DDNS Registration


Question.
1.Is the DNS server is authoritative or non-authoritative?

Super Advisor

Re: ILO DDNS Registration

Authoritative. (Active Directory Integrated). We have Secure Dynamic Updates enabled (and we aren't turing it off) -- did not see any mention of potential issues with this in the documentation.
Advisor

Re: ILO DDNS Registration

Have you gotten anywhere on this. I am having the same issur runnin 1.84 firmware. I have never gotten this to work.
Honored Contributor

Re: ILO DDNS Registration

Update to the latest iLO firmware.

iLO 1.84 has this note in the readme:
4) Corrected a problem that prevented iLO from correctly registering when configured to use a non-authoritative DDNS server.

so that probably fixes this symptom.

However, iLO 1.87 is now available for download here:
http://h18004.www1.hp.com/support/files/lights-out/us/locate/69_5867.html
Trusted Contributor

Re: ILO DDNS Registration

Use the following tool to integrate iLO or Riloe with AD:

http://h18004.www1.hp.com/support/files/lights-out/us/download/23896.html

Occasional Visitor

Re: ILO DDNS Registration

I have the same with iLo cards not registering their names in DNS, with both versions 1.82 and 1.84 of the iLO firmware. For the test zone, "Enable DHCP" is disabled, and "Register With DDNS Server" is enabled. I have tested this in an environment where the zone is AD integrated and "accepts both secure and nonsecure updates".

When I perform a detailed DNS debug logging, the DNS server does respond, with an "RCODE" of 9 instead of the usual 0 (no error). The packet looks something like this:


20061102 16:23:26 124C PACKET UDP Snd 10.10.16.53 0003 R U [09a8 NOTAUTH] (5)DOMAIN(3)COM(0)
UDP response info at 02A9F700

Do the HP schema extensions have to be activated in order to get AD-integrated DDNS registration to work?
Occasional Visitor

Re: ILO DDNS Registration

I found a solution to my original problem. The zone that I was trying to register the iLo card in was created in Windows DNS as a new zone in its parent domain, instead of being created as a new zone at server level with its own delegation, SOA records, and NS records. It seems to make a difference, as I can register the iLo card successfully in the parent domain. I guess that this is part of the "active directory domain is not authoratative" problem. I will create a new domain for the remote control cards in the parent domain and see if they register successfully.
Occasional Visitor

Re: ILO DDNS Registration

I have many iLOs that are at the 1.89 rev of firmware, use static IP settings, have register with WINS and DDNS enabled, all WINs and DNS servers are listed by IP. The DNS servers are AD integrated and dynamic updates are set to "Secure only". None of the iLOs are registering with the DNS server. Is this caused by the "secure only" dynamic updates setting?
Occasional Contributor

Re: ILO DDNS Registration

I am also having this same issue.  Are iLO 4's capable of Secure DDNS registration at all?  Everytime we move a Blade server, DNS does not update the iLO address.. I have more than 250 iLOS that are basically none functional... IDEAS?

thank you

adkg12