Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

ILO performance is often very poor

Occasional Visitor

ILO performance is often very poor

the issues we have with ILO include

- Improper handling of keyboard input when ILO session are open, forcing us to close ILO session to resolve.
- The performance of ILO is often very poor, with flashing and blinking screen with Win2k8
- Periodic inability to connect

Has anyone else seen such behavior?
Have you found a solution?
Yarrrr!
6 REPLIES
Honored Contributor

Re: ILO performance is often very poor

hi Jim

Which server? in thay way we can know if your are talking ilo or ilo2.


server has latest firmware?
ilo : 1.91
ilo2: 1.5

network congestion?
have test you ilo using a cable between that server and a computer?


regards
Didn't your momma teach you to say thanks!
Honored Contributor

Re: ILO performance is often very poor

may be you haven't enabled high mouse performance and for keyboard issue looks like old f/w.
Occasional Visitor

Re: ILO performance is often very poor

Machines are DL360 G5
ILO v 1.43
We are using approximately 500 machines though not concurrently.
Network bandwidth is more than adequate.
Yarrrr!
Honored Contributor

Re: ILO performance is often very poor

Occasional Visitor

Re: ILO performance is often very poor

I work with Jim and tried loading 1.5 firmware a few weeks ago on a few machines to see if it helped. Unfortunately however, it has not helped with the flickering, keyboard snatching, or the random can't connect issues (though admittedly those aren't very common).

The most frequent annoyances are the keyboard disappearing, which tends to happen around 10-45 minutes after opening 3 or more iLO sessions concurrently to different machines. At some point your keyboard will be swiped by one of the sessions, or your keystrokes garbled. In any case the only way to resolve the issue is to close the ilo Sessions and reopen them.

The flickering with 2008 almost makes me think it's an issue with 2k8's shading. The iLO bar at the top of the window is not colored appropriately on 2k8 machines. Additionally, the flickering only happens (to my knowledge) when you are resizing the window, or making any modification to the iLO window or using the iLO bar at the top.

Both of these issues happen regardless of if we are using the HP Integrated Console or the Java Console.

The mouse has no bearing on this, however we are using the high performance mouse option. All of our iLO machines are set to 100Mb Full Duplex. The switches they are running on are all Cisco 48 port 1Gb switches, and within a rack we have no more than 28 machines. We have more than enough bandwidth for iLO traffic, given that we may only have 5-10 machines active in a rack at any one time.

We've had 28 machines going full throttle 1Gb Ethernet flooding the network of the switch they were on, and the switch wasn't what was pushed over. So bandwidth is not a question here.
Occasional Visitor

Re: ILO performance is often very poor

Additionally one other issue that is very annoying, and I suspect the root cause of the keyboard issue, though I can't prove it, is that iLO seems to have no network redundancy built in. it cannot handle dropped packets well at all.

For example, if your client machine (the one you are using to view iLO sessions with) has a DHCP address, and it renews while you have a session open, your iLO session hangs and is lost, sometimes crashing the browser itself. iLO cannot recover from this brief moment if interrupted connectiviy, while most other network activity simply restablishes connection (file copies, RDP, etc).

I suspect that at some point during the multiple sessions, a packet is dropped, and rather than terminating the session, or rebroadcasting a packet (perhaps a sort of keep alive type thing), iLO gets confused as to which session has keyboard control, and the keyboard becomes locked into a single ilo session (or even multiple ilo sessions).