Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

Ilo login issue with DNS name

SOLVED
Go to Solution
Advisor

Ilo login issue with DNS name

I have discovered that Ilo will not login when using a dns name containing an underscore, it will login with a dns name using a dash however.

servername_ilo will not login
servername-ilo will login

Is it possible to request a fix in the firmware to resolve this?
Anyone else noticed this?

Thanks
2 REPLIES
HPE Pro

Re: Ilo login issue with DNS name

I think they are just following RFC standards

Take a look at http://en.wikipedia.org/wiki/Hostname#Restrictions_on_valid_host_names






__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Honored Contributor

Re: Ilo login issue with DNS name

Correct. While Windows has allowed the underscore for legacy compatibility with NetBIOS names the recommendation is to migrate away from that for DNS compatibility.

http://technet.microsoft.com/en-us/library/cc778792%28WS.10%29.aspx

"If you have an investment in using NetBIOS names to support legacy Microsoft networking technology, it is recommended that you revise NetBIOS computer names used on your network to prepare for migration to a standard DNS-only environment. This prepares your network well for long-term growth and interoperability with future naming requirements. For example, if you use the same computer name for both NetBIOS and DNS resolution, consider converting any special characters such as the underscore (_) in your current NetBIOS names that do not comply with DNS naming standards. While these characters are permitted in NetBIOS names, they are more often incompatible with traditional DNS host naming requirements and most existing DNS resolver client software."
//Add this to "OnDomLoad" event