Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

LO100 Virtual Media needs port 5901/tcp open to client

Occasional Visitor

LO100 Virtual Media needs port 5901/tcp open to client

Have been tearing out clumps of hair for 3 hours trying to get Virtual Media to appear in BIOS and boot on a DL185 G5 using the built-in LO100 with Select license.

Despite locating either a suitable ISO image or a local CD-ROM drive, adding it to the Virtual Media list and clicking 'Connect', the media were not showing up as they should (in the Boot > CD-ROM drives part of BIOS) and not booting.

Apparently the ILO was trying to connect back to my client machine on port 5901/tcp which my firewall does not normally NAT to my machine. This is not mentioned in the User Guide, nor in the KVM software, and no warning, error message or other indication of this is displayed.

After forwarding that port, it finally works as expected.

I hope my posting here can prevent someone else going through the same frustration.

Please document this requirement!
3 REPLIES
Occasional Contributor

Re: LO100 Virtual Media needs port 5901/tcp open to client

How do I can forward the port 5901 to my local pc in the local configuration?

I have the firewall disabled.

Thanks
Pedro
Occasional Visitor

Re: LO100 Virtual Media needs port 5901/tcp open to client

That will depend on your own circumstances. In a typical home environment, your connection will be via a router which you must configure to forward port 5901/tcp, perhaps following one of the many guides available at: http://portforward.com/
Occasional Visitor

Re: LO100 Virtual Media needs port 5901/tcp open to client

Thank you so much for that info.
I searched and searched, and tried everything I could, including DMZ.

I have had an HP tech rep do a remote session with me, and he couldn;t figure it out.

5901 fixed the issue beautifully.

To this point, i had been using  a windows RDP session into a VPS to get remote media to work.

Makes for a bad iLo experience, to work it through an RDP session