Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

Problems Addressing iLO

Occasional Visitor

Problems Addressing iLO

I am trying to assign an IP address to a number of iLO's in some DL740's recently purchased. The network is in a number of VLAN's so I am trying to use a subnet of 255.255.255.192. This has worked on other Remote Management Cards in the past but when I try to save the config, I receive the error, 'cannot set IP address to broadcast address'
If I change the subnet to 255.255.255.0 it accepts the config but then, of course, I cannot connect to the iLO.

Any ideas anyone??

Thanks

Chris
1 REPLY
Honored Contributor

Re: Problems Addressing iLO

I was just able to use an IP address of 10.10.10.1 with a subnet of 255.255.255.192 using both the web interface and the console on a DL740 with iLO firmware 1.25. If I try 10.10.10.63 with that same subnet, I get the same error that you did.

I'm not a whiz at IP, so this led me to some investigation and I found the following reference on IP routing fundamentals:

http://www.networkcomputing.com/netdesign/1122ipr3.html?ls=NCJS_1122bt#three

It seems that every network has a "broadcast address" that can be used to talk to everyone simultaneously on the network. Using a subnet calculator, the broadcast address for a network in the range of 10.10.10.1-62 is 10.10.10.63. The range 10.10.10.64-126 has a broadcast address of 10.10.10.127. (Do a Google search for subnet calculators)

You can't set an individual IP address to be the same as the broadcast address for the subnet. Windows also complains:

"The combination of IP address and subnet mask is invalid. All of the bits in the host address portion of the IP address are set to 1. Please enter a valid combination of IP address and subnet mask."