Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

RILOE remote console problem in Windows 2003

Occasional Visitor

RILOE remote console problem in Windows 2003


We're getting this problem across about 15 servers running Windows 2003 SP1 with RILOE II's installed. Here's an example system:

Server: Proliant DL520 G2 (firmware:09/15/2004)
(headless server, no splitter cable attached)
Card: RILOE II (firmware: 1.16)
Driver: Latest RILOE drivers from 7.40 PSP

Symptoms:
After reboot, RILOE appears fine. Go to remote console tab and mouse works but when click ctrl-alt-del the RC screen freezes. Back on status page now says " Remote Insight Mouse Cable: Disconnected ". Server requires a reboot to get it clear and then does the same thing again.

Troubleshooting:
* confirmed it's a 30 pin cable b/n RILOE in slot 1 and m/b RILOE connector
* probably not java issue as same java client connects fine to ILO advanced pack on other server.
* confirmed not a network issue as connected via cross-over cable w/ same problem and no errors on cisco switch port
* shouldn't be name resolution as accessing RILOe's via IP address.
* suspect OS/driver conflict. Only one of our servers with a RIB is running Windows 2000 and it works fine (but no mouse) so suspect this is may be an issue with the RILOE driver conflicting with Win2k3 over control of mouse/kbd ?

This looks similar....
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=975202

QUESTIONS
1) any ideas?
2) any known conflicts when there's an ILO and a RILOE (ie RIB) in one machine
3) are most people now moving to ILO's with advanced packs in all new servers? (rather than ignoring the ILO and installing RIBs ?) - feature set now pretty similar
4 REPLIES
Occasional Visitor

Re: RILOE remote console problem in Windows 2003

slight clarification to "the RC screen freezes". It's more that you lose any control from your mouse / keyboard (ie after a while the screen saver comes up but you just can't interrupt it with either the mouse or ctrl-alt-del).
Trusted Contributor

Re: RILOE remote console problem in Windows 2003

Are you using an IP KVM switch?
Occasional Visitor

Re: RILOE remote console problem in Windows 2003

Here's the magic link we were missing. (big thanks to Riju @ HP Tech for the help with this one)

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=PSD_EM020320_CW01

Basically the first solution of "enabling hot plug keyboard" is not available on the newer servers so we need to "disable host keyboard". This fixes the problem but is a bit of a pain as, if we need to go onsite, we'll have to remember to reenable the keyboard. Anyway, just thought I'd update the post so anyone else with this problem can find the workaround.

ps. I would be interested to hear from anyone else running DL580 G2's or DL380 G3's with Windows 2003 SP1 and RILOE's who isn't using the "disable host keyboard" workaround.

pps. BWC, thanks for the reply but no, no IP KVM switch attached.
Honored Contributor

Re: RILOE remote console problem in Windows 2003

1) any ideas?
Sounds like you have the answer...

2) any known conflicts when there's an ILO and a RILOE (ie RIB) in one machine
iLO self-disables if RIB is installed. This avoids any conflicts, and also disables hot plug keyboard support because that may be provided by iLO.

3) are most people now moving to ILO's with advanced packs in all new servers?
In general, yes, since the latest iLO firmware has pretty good feature consistency with RILOE. Also, iLO does not require a PCI slot. Those continuing to use RILOE II are generally re-using an asset and avoiding the cost of an iLO license.