Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

Schema Ext. HP Roles not displaying.

Occasional Advisor

Schema Ext. HP Roles not displaying.

The schema updates went fine. In the ADMC, if I select "New" there is no HP Role to add. I cannot figure out how to add one.

If I select Custom search in AD I can search on HP Target & Role but do not see any way to add them.

Any hints as to what may be going on here or maybe another way I can add the roles?
10 REPLIES
Frequent Advisor

Re: Schema Ext. HP Roles not displaying.

On which version of Windows does the AD MMC run?
Occasional Advisor

Re: Schema Ext. HP Roles not displaying.

I have tried the AD MMC on XP X64, Vista 32 bit, Server 2003 32bit, and XP 32bit. All with latest service packs.
Honored Contributor

Re: Schema Ext. HP Roles not displaying.

hi

I supposed you're following the steps from here

http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c00190541/c00190541.pdf

specially page number 8
"Once the schema has been extended, the new attributes are viewable using the AD Schema MMC snap-in installed previously..."


I mean messages regarding creating the 3 new classes:
HPQTarget, HPQPolicy and HPQRole

are fine ? you can see them? as the roles were created successfully?

regards
Didn't your momma teach you to say thanks!
Trusted Contributor

Re: Schema Ext. HP Roles not displaying.

You had extended the schema. Did you also install the snapins? If so, close you MMC, then reopen. Make sure your mmc is closed when you install the HP snapins.
Occasional Advisor

Re: Schema Ext. HP Roles not displaying.

Yes, I see all the new classes in the schema snap-in. Yes, the MMC's are installed. Everything was done according to the c001905
41.pdf. We did it by the book with no errors, however I still cannot add any new HP Roles.
Trusted Contributor

Re: Schema Ext. HP Roles not displaying.

Chris,

What version of Windows is AD running on? Did you install the snapins on the client that is running the MMC? XP should work. don't know about Vista. Did you try to run the MMC on the server and see if you can see the hp snapins?

bwc
Occasional Advisor

Re: Schema Ext. HP Roles not displaying.

The entire forest is W2K3 SP1 (Native Mode). Yes the snap-in's are installed. Yes, I have tried running in on multiple servers including the Schema Master.

I did see a post on making sure it is the English language version, it is.

I am thinking I may have to call HP on this one.
Occasional Advisor

Re: Schema Ext. HP Roles not displaying.

Well, I called HP but they where unable to help. It seems I need some sort of software contract before I can get support with this. It was recommended I call Microsoft, but somehow I doubt that will get me very far.

I wonder if there is a way to add the Roles outside of the MMC. I will look into that next.
Honored Contributor

Re: Schema Ext. HP Roles not displaying.

Doing the searches will be negative because it is looking for objects. The schema extension defines new classes and does not intrinsically create the objects. The MMC snap-in enables you to create the objects.

Since the schema extension succeeded and you cannot see the new objects in MMC, this is where to look. It sounds like all the regular pitfalls have been addressed:
- MMC is an English install
- you installed the MMC snap-ons on the same system you are running MMC on
- you extended the schema on the same directory you are attempting to create the objects
- the account you are using has appropriate directory administrative rights

So, you cannot create new HPQ Roles or HPQ LOM Objects? Or you cannot see these in the MMC?
Occasional Advisor

Re: Schema Ext. HP Roles not displaying.

Resolved. Dumb mistake.

I ran the snapin installer on another machine and it is working fine (Vista X64). On some of the machines I am sure it was never installed.

I was assured it had been run on the original install with no luck but I will have to revisit and see if this is the case.

The instructions state:
"In the Directory Support screen, click Snap-in Installer to install the AD Schema MMC snap-in from the \i386\adminpak.msi file on the CD"

I think it was assumed this was the standard AD Tools and it would just reinstall them.

Sorry for trouble, thanks for all the help.