Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II)
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Media Applet does not load java applet - it shows blank window

Ganapathi Ram
Occasional Visitor

Virtual Media Applet does not load java applet - it shows blank window

Hi

I am accessing ILO from linux machine using firefox browser.
I have installed java plugin so that i can open java applets. Good, the java plugin works, i can open remote console, to confirm that the there is no problem with the java plugin.
But to my surprise, when i click on "Virtual Media Applet" link under "Virtual Media" tab, a new child window opens but does not display any thing.

I have no clue how to continue. Any help, appreciated. Fighting from a day on this :(
Is there any prerequisite for the page to open ...like there should be a virtual disk present...some thing like that? Because the same page opens well when i tried from windows machine, using firefox only!!!

If i can use command line interface (from linux machine) i dont know the procedure...ILO guide...i felt it did not explain much in this regard for linux users.

Thanks
Ram
3 REPLIES
barnett chan
Trusted Contributor

Re: Virtual Media Applet does not load java applet - it shows blank window

Your java is not loaded correctly. Please use Java 1.4.2 for iLO 2. Make sure you create a soft link to the java plug in.
Micheal Waltz
Occasional Visitor

Re: Virtual Media Applet does not load java applet - it shows blank window

Same thing happens to me and the only way to bring up the virtual media applet is by using windows.

However, you can mount virtual media via an web server using command line ILO or a script:
















More information on this is in the ILO CLI manual.

http://www.google.com/url?sa=t&source=web&cd=1&ved=0CBIQFjAA&url=http%3A%2F%2Fh20000.www2.hp.com%2Fbc%2Fdocs%2Fsupport%2FSupportManual%2Fc00294268%2Fc00294268.pdf&ei=YNNETNaRKpPQsAOtl-TlDA&usg=AFQjCNGIUnOMAcZIjZdDheOe04zB0Lqp2Q&sig2=R48__oifySMBZddIHXMB8g
Ken Green
Advisor

Re: Virtual Media Applet does not load java applet - it shows blank window

I think your problem is using the 64bit version of Firefox and the JRE.
I can only get the 32bit JRE to work with this applet.
RHEL installs both the 32bit and 64bit version of the Firefox.

I modified the /usr/bin/firefox file (it's a shell script). It uses the uname -m command to decide whether to run the 32bit or 64bit version and sets a MOZ_ARCH env. var. I changed this so it lets the user set the variable first if they want to control the behaviour. You then install the 32bit JRE and setup the link to the 32bit plugin lib.

Having done that I could run both the remote console and remote media applet from inside Firefox.