Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

XML script work the same

Occasional Advisor

XML script work the same

does the XML script work the same on a RILOE, RILOE II, and ILO? I have 300 RILOE, ILO, and RILOE interfaces that I need to add a new account to. It works with RILOE's but not the ILO's. The XML is below. I think the problems is with the




USER_NAME="Application Support"
USER_LOGIN="XXXXX"
PASSWORD="password!">











3 REPLIES
Honored Contributor

Re: XML script work the same

Most of the parameters are shared between iLO and RILOE, however there are two inconsistencies:
1) LOGIN_PRIV is not supported on iLO
2) you do not have the CONFIG_ILO_PRIV

Consider a script like this:















Occasional Advisor

Re: XML script work the same

The ILO works fine but I get the following error on RILOE and RILOEII and the account is not created.

MESSAGE='Syntax error: Line #8: syntax error near "<" in the line: "< CONFIG_ILO_PRIV value = "No" />"'
/>

Honored Contributor

Re: XML script work the same

You can use the same XML script to configure users for both RILOE and iLO, however not all of the tags apply, so there would be some user privileges that would remain in their default states.

The CONFIG_ILO_PRIV is not supported by RILOE.
The LOGIN_PRIV is not supported by iLO.

I have asked the firmware teams to look at tolerating the foreign XML tokens so that the scripts will not fail when used across the Lights-Out products.