Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

dev/hpilo not present

Occasional Advisor

dev/hpilo not present

Hi all,

Can someone help with this.

 

Server -> HP proliant DL380

OS -> RHEL 4

ILO card is working. But password is LOST.

 

I wanted  to reset it using the hponcfg utility.

 

-------

#hponcfg
HPONCFG RILOE II/iLO setup and configuration utility
Version 2.2 (c) Hewlett-Packard Company, 2009
 
ERROR:  Could not find the iLO/RILOE-II Device Node.
        Please check if the iLO driver module is installed and running properly.
        ACTION REQUIRED: Install/Re-install hp Lights-Out driver package('hp-ilo' RPM) for iLO.

 

-----

I re-install the hp-ilo rpm... but error persists.

 

lspci shows the ilo card

01:04.0 System peripheral: Compaq Computer Corporation Integrated Lights Out Controller (rev 01
01:04.2 System peripheral: Compaq Computer Corporation Integrated Lights Out  Processor (rev 01)

 

but

/dev/hpilo does not exist.

 

and a strace to hponcfg shows

open("/dev/hpilo/d0ccb0", O_RDWR|O_EXCL) = -1 ENOENT (No such file or directory)

 

Which could be the problem ?  What can i do ?

 

14 REPLIES
HPE Pro

Re: dev/hpilo not present

after installng the .RPM, did you start the iLO channel driver?

 

/etc/init.d/hp-ilo status

 

if it's not running then;

 

/etc/init.d/hp-ilo start

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: dev/hpilo not present

#/etc/init.d/hp-ilo status
Status of hp-ilo:
  hpilo driver is NOT loaded...


#/etc/init.d/hp-ilo start
  Starting hp-ilo: [FAILED]
  Check installed kernel failed

HPE Pro

Re: dev/hpilo not present

[ Edited ]

What version of RHEL4? what is the current kenel version?

 

What version of hpilo rpm did you instal?




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: dev/hpilo not present

Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
2.6.9-34.0.2.ELsmp i386 GNU/Linux
hp-ilo-8.4.0-106.rhel4

hponcfg-2.2.0-5

HPE Pro

Re: dev/hpilo not present

you might try this version, the instal notes state it should rebuild itself to work on the current kernel

 

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=1146658&swItem=MTX-89f2adf991f74d53bf945b6629&prodNameId=1135772&swEnvOID=2025&swLang=8&taskId=135&mode=4&idx=1




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: dev/hpilo not present

Thanks a Lot Jimmy !!!!

I will try it in the next days.....

I let you know....

 

Occasional Advisor

Re: dev/hpilo not present

Well.... i am afraid it did not work.

 

-I install hp-ilo-8.5

#rpm -qa |grep hp-ilo
hp-ilo-8.5.0-1.rhel4

 

but

#/etc/init.d/hp-ilo start
  Starting hp-ilo: [FAILED]
  Check installed kernel failed

 

 

#hponcfg
HPONCFG RILOE II/iLO setup and configuration utility
Version 2.2 (c) Hewlett-Packard Company, 2009
 
ERROR:  Could not find the iLO/RILOE-II Device Node.
        Please check if the iLO driver module is installed and running properly.
        ACTION REQUIRED: Install/Re-install hp Lights-Out driver package('hp-ilo' RPM) for iLO.

HPE Pro

Re: dev/hpilo not present

does the file "/opt/hp/hp-ilo/make.log" exist? if so post the contents




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: dev/hpilo not present

No. The file does not exist.

 

#ls -l /opt/hp/hp-ilo/*
-rwxr-xr-x   1 root root 7133 Jul  5  2009 /opt/hp/hp-ilo/check_install_kernel.sh
-rwxr-xr-x   1 root root  675 Jan 21  2008 /opt/hp/hp-ilo/hp-ilo.license
-rwxr-xr-x   1 root root 3593 Feb  1  2010 /opt/hp/hp-ilo/hp-ilo.spec
-rwxr-xr-x   1 root root 8839 Jul  8  2007 /opt/hp/hp-ilo/hprpm.xpm
-rwxr-xr-x   1 root root 2655 Nov 23  2008 /opt/hp/hp-ilo/Makefile
-rwxr-xr-x   1 root root 2131 Nov 23  2008 /opt/hp/hp-ilo/make_install
-rwxr-xr-x   1 root root 2266 Jul  5  2009 /opt/hp/hp-ilo/rebuild

/opt/hp/hp-ilo/bin:
total 120
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-42.EL
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-42.ELhugemem
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-42.ELsmp
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-55.EL
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-55.ELhugemem
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-55.ELsmp
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-67.EL
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-67.ELhugemem
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-67.ELsmp
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-78.EL
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-78.ELhugemem
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-78.ELsmp
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-89.EL
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-89.ELhugemem
drwxr-xr-x  2 root root 4096 Sep 12 07:21 2.6.9-89.ELsmp

/opt/hp/hp-ilo/drivers:
total 8
drwxr-xr-x  2 root root 4096 Sep 12 07:21 misc

/opt/hp/hp-ilo/man:
total 8
-rwxr-xr-x  1 root root 3700 Jul  5  2009 hp-ilo.4

HPE Pro

Re: dev/hpilo not present

you might try an older version that has the pre-built binary for your kernel

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: dev/hpilo not present

I made it work !!

Thanks for your support Jimmy !! You really help me !!

 

I made a symbolik link of my kernel to one of the kernels listed in /opt/hp/hp-ilo/bin ..... and MAGIC !!

 

Occasional Visitor

Re: dev/hpilo not present

Hello

 

can you help me to solve this problem i have the same problem and can not fix this

 

 

Advisor

Re: dev/hpilo not present

I'm also having this problem except on a RH5.3 machine.  The problem I read about here is a warning not to install the hp-ilo package on 5.3 or later.....

 

Also the "solution" above to link a package doesn't show exactly what happened, what was linked, etc. So I have a glimmer of a solution, but no a specific one...

 

 

 

BUT...

 

[root@sca12fe001 ~]# uname -a
Linux sca12fe001 2.6.18-92.1.10.el5.xs5.0.0.39xen #1 SMP Thu Aug 7 14:58:14 EDT 2008 i686 i686 i386 GNU/Linux

[root@sca12fe001 ~]# hponcfg
HP Lights-Out Online Configuration utility
Version 4.4.0 Date 06/13/2014 (c) Hewlett-Packard Company, 2014

ERROR: CpqCiCreateFunc() 0 time failed.
Driver Error Code:(1,1h).
Driver Error Message: CPQCIDRV driver is not loaded.

ERROR: CpqCiCreateFunc() 1 time failed.
Driver Error Code:(1,1h).
Driver Error Message: CPQCIDRV driver is not loaded.
ERROR:  Could not find the Management Processor Device Node.
        Please check if the iLO driver module is installed and running properly.
        ACTION REQUIRED: Install/Re-install hp Lights-Out driver package('hp-ilo' RPM) for iLO.

 

 

Occasional Visitor

Re: dev/hpilo not present

ERROR: CpqCiCreateFunc() 0 time failed.
Driver Error Code:(1,1h).
Driver Error Message: CPQCIDRV driver is not loaded.

ERROR: CpqCiCreateFunc() 1 time failed.
Driver Error Code:(1,1h).
Driver Error Message: CPQCIDRV driver is not loaded.
ERROR: A general system error occurred while detecting Management Processor.
ACTION REQUIRED: Check if iLO and iLO driver are up and running.

 

 

 

We are getting the above error in hponcfg...can any one help us on this ?