Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

iLO 1.42 and 1.50 have DNS lookup problemes for directory services

Valued Contributor

iLO 1.42 and 1.50 have DNS lookup problemes for directory services

I have correctly configured the ILO network paramenters to use my Windows Server 2003 DNS servers, and I input the correct domain name.

However, when I input the FQDN or just hostname in the directory services and do a test, it says that it can't lookup the hostname.

If I input the IP address then the directory servies authentication works. The LDAP server and DNS server are the same box.

Does anyone have a solution?
9 REPLIES
HPE Pro

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

Where did you input this information? Can you send screen shots?
Ken Henault
Infrastructure Architect
HP
Valued Contributor

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

There's only one place it input 3 DNS servers, and that's on the network configuration page in iLO. All three are valid DNS servers and all are also DCs.

HPE Pro

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

You ALWAYS have to enter DNS servers as an IP Address. If you enter a host name, it has no way to do the name resoliutionhis is not unique to ILO.
Ken Henault
Infrastructure Architect
HP
Valued Contributor

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

Yes the DNS servers are entered as IP addresses.
Trusted Contributor

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

Derek,
Sounds like the dns is not the problem but the domain name in the network settings page. It's either not set or set to the wrong domain name. iLO uses this field if a name is used instead of the IP address for the directory server.
Valued Contributor

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

The problem is with iLO. If you have 'dynamic DNS' updates disabled, then iLO will not resolve the DNS name of the directory server. If it is enabled, then it will resolve it.

This happenes even when manual iLO DNS entries are in the DNS server. So it has nothing to do with iLO actually updating the DNS server with anything.

This is a firmware bug I and hope HP fixes it.
Honored Contributor

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

We are looking into this. For the time being, you can workaround the issue in one of these ways:
1) use the IP address of the directory server
2) Leave "Register with DDNS Server" enabled (Yes).
Advisor

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

Have you tried using the FQDN in the Directory Server Address field. We use DFS for ours but the FQDN should work the same. Hope this helps
Advisor

Re: iLO 1.42 and 1.50 have DNS lookup problemes for directory services

I'm actually have the same issue with an ILO at firmware rev 1.41. Strange but I agree this is a firmware bug.