Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

iLO 3 RIBCL rejecting properly escaped XML document characters.

Occasional Advisor

iLO 3 RIBCL rejecting properly escaped XML document characters.

I have a user configured in my iLO 3 server with a password of 12345678>

When I present a login xml block of <LOGIN USER_LOGIN="user" PASSWORD="12345678&gt;"> with the > character properly escaped as per XML standards,  it is rejected as a login failure.

When I present a login xml block of <LOGIN USER_LOGIN="user" PASSWORD="12345678>"> it is accepted.

Ok, so RIBCL, for reasons unknown, will not accept properly escaped XML.

But when a user has a " character in their password and I present <LOGIN USER_LOGIN="user" PASSWORD="12345678""> I get a syntax error along with some other invalid XML.

 

So some questions that I hope someone can answer so I don't have to spend days testing for more RIBCL problems.

Is this broken handling of XML escaping present in iLO2?

 

Does RIBCL do proper XML character escaping in it's responses? I might have a > in my server name, does RIBCL properly escape the XML in the response for GET_SERVER_NAME? If it doesn't then my nice neat .NET code to parse the responses is going to break due to invalid XML.

 

Where can I find a list of other special characters that breaks RIBCL XML parsing? I assume an unescaped " in any input block is going to break RIBCL, I would bet there are more characters that will break RIBCL XML parsing.