Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II)
cancel
Showing results for 
Search instead for 
Did you mean: 

iLo2 / VSP on RHEL5 missing console messages

kajukenbo
Occasional Visitor

iLo2 / VSP on RHEL5 missing console messages

Hello all.

I have configured iLo2 with the VSP on a RHEL5.5 box.
The console works, I can ssh in and VSP to the console, however a chunk of the boot-up messages are missing.
Almost everything on boot-up after SELinux is skipped, until the login prompt appears:
---------------
SELinux: Disabled at runtime.
type=1404 audit(1277390617.313:2): selinux=0 auid=4294967295 ses=4294967295
VxVM vxdmp V-5-0-897 dmplinux:vxdmp: Cannot find device number for root<4>
VxVM vxdmp V-5-0-34 added disk array OTHER_DISKS, datype = OTHER_DISKS

VxVM vxdmp V-5-0-34 added disk array 046CD, datype = xp24k

FS-Cache: Loaded
CIFS: Unknown mount option _netdev

Red Hat Enterprise Linux Server release 5.5 (Tikanga)
Kernel 2.6.18-194.3.1.el5 on an x86_64

myhost login:
--------------

The missing output is basically the RHEL "[OK]" (or not) results of the init processes.
That is actually the data I'm looking for.

The same data does display on the Java browser console but it all scrolls by too fast to be of use. I would much rather stay on a ssh connection anyway.

Does anyone know what is wrong?

Thanks,
Dave
3 REPLIES
kajukenbo
Occasional Visitor

Re: iLo2 / VSP on RHEL5 missing console messages

To clarify,

The messages are missing on the "Remote Serial Console" in Java and the VSP serial console connected from ssh.

The Java "Remote Console" displays all of the messages in Firefox.

Thanks

kajukenbo
Occasional Visitor

Re: iLo2 / VSP on RHEL5 missing console messages

Easy to fix, hard to spot...

I needed to change:
"console=ttyS0,115200n8 console=tty0"
on the kernel line in grub

to: "console=tty0 console=ttyS0,115200n8"

Once I put the "console=tty0" part first then all of the messages displayed properly.

Don't forget to add in the beginning of /etc/grub.conf:
serial -unit=0 -speed=115200
terminal --timeout=5 serial console

You still need in /etc/inittab:
# Run gettys in standard runlevels
s0:2345:respawn:/sbin/agetty 115200 ttyS0 vt100

and you probably want to:
echo "ttyS0" >> /etc/securetty
kajukenbo
Occasional Visitor

Re: iLo2 / VSP on RHEL5 missing console messages

solved it myself.