Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
Showing results for 
Search instead for 
Do you mean 

iLo2 console access and NVidia mezzanine card in WS460c G6 Blade not working

SOLVED
Go to Solution
Occasional Visitor

iLo2 console access and NVidia mezzanine card in WS460c G6 Blade not working

We have a ProLiant WS460c G6 Blade Workstation with a Mezzanine NVIDIA GPU Quadro FX 2800M (G92GL).

We run RedHat 5 update 4 and Nvidia driver 256.35

For Server Side Rendering in Virtual GL we need to run runlevel 5. The X server starts correctly, gdm does not crash and server side rendering works fine.

But our iLo console will turn black and doesn't show anything (vt switch with ++ doen NOT work). We would like to have a working console in case we get issues with the machine.

As I understand the documentation the iLo2 is connected to the internal ATI vga adapter. If I configure the ATI driver I do get an image in runlevel 5.

I'm looking for help to get both the NVidia Xorg server up and running and get a console on the iLo2 (text or graphical)

Included is my xorg.conf, Any suggestions?
3 REPLIES
Honored Contributor

Re: iLo2 console access and NVidia mezzanine card in WS460c G6 Blade not working

iLO2 graphical remote console is implemented in hardware (i.e. requires no operating system drivers or support) and accomplishes this by having a direct, high speed connection between the iLO2 processor and the onboard graphics chip so it can snoop the RAMDAC directly. When you install a replacement video card such as the Nvidia with a PCI Express interface, it defeats the ability of iLO2 to get the information it needs.

It sounds like you have in-band access to X, so the missing piece is how to have some kind of out-of-band (i.e. iLO2) access in case of "issues" as you say above. That's going to have to be text console access, but that will allow you to start/stop X, reboot, change configurations, etc. You'll need to enable RH for a serial console and then follow the instructions in the iLO2 user guide (http://www.hp.com/go/ilo --> iLO2 user guide) for using the Virtual Serial Port.
Occasional Visitor

Re: iLo2 console access and NVidia mezzanine card in WS460c G6 Blade not working

Thanks for the suggestion, I added the following line to /etc/inittab

co:2345:respawn:/sbin/agetty ttyS0 57600 vt100-nav

And did a 'telinit q', virtual console works like a charm via web and ssh access. This is just what we needed.
Occasional Visitor

Re: iLo2 console access and NVidia mezzanine card in WS460c G6 Blade not working

Solution implemented (see thread)
//Add this to "OnDomLoad" event