HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Secure OS Software for Linux
cancel
Showing results for 
Search instead for 
Did you mean: 

SSL with client certificate verification

 
Jun Yoda
Occasional Visitor

SSL with client certificate verification

Has anyone tried settting up SSL with client certificate verification on HP-LX? I've setup a web and a mcga compartment. I've also placed a "getenv" CGI in the mcga compartment to display all environment variables that could be used a parameters for executing CGI programs.

The problem is that I can't get SSL_CLIENT_CERT or SSL_SERVERT_CERT to be displayed. I can display standard environment variables such as HTTP_HOST,REMOTE_HOST, ...etc. etc.

I'm wondering if anyone has experienced similar problems. It could be that case that I'm not configuring HP-LX or Apache correctly.
2 REPLIES
Hal Rottenberg
Frequent Advisor

Re: SSL with client certificate verification

We addressed this with patch HPTL_00023 which has since been superseded by HPTL_00029.

"The HTTPS CGI environment variable is not set to "on" during secure server operation."

http://support1.itrc.hp.com/service/patch/patchDetail.do?patchid=HPTL_00029&context=mv:intellinux:hplx1.0

Hope this helps!

Hal Rottenberg
If at first you don't succeed, then skydiving isn't for you.
Jun Yoda
Occasional Visitor

Re: SSL with client certificate verification

Thanks Hal for the reply.

I've applied the latest patch, HPTL_00029. HTTPS is set to "ON". But I still cannot get SSL_CLIENT_CERT or SSL_SERVERT_CERT to be passed onto my CGI. What could be the problem?