cancel
Showing results for 
Search instead for 
Did you mean: 

SSH2 no password

SOLVED
Go to solution
Sivasingam Santhakumar
Frequent Advisor

SSH2 no password

Dear Gurus,

I am trying backup Linux server on a tape drive attached to a Alpha running Tru64 5.1 and SSH is
"SSH Secure Shell Tru64 UNIX 3.2.0". I am trying pull the data rather than push. I am setting Tru64 to talk to Linux as root with out password.
I can make other Linux boxes to talk to this Linux without password but not to Tru64. I can pull the data by entering the root password, but I don't want that. My ssh debug output is below.
Can someone where is the problem is?.

alphads20e#ssh -v staff-prod
debug: SshAppCommon/sshappcommon.c:185: Allocating global SshRegex context.
debug: SshConfig/sshconfig.c:2820: Metaconfig parsing stopped at line 3.
debug: SshConfig/sshconfig.c:2728: Unable to open //.ssh2/ssh2_config
debug: Connecting to staff-prod, port 22... (SOCKS not used)
debug: Ssh2/ssh2.c:2332: Entering event loop.
debug: Ssh2Client/sshclient.c:1452: Creating transport protocol.
debug: SshAuthMethodClient/sshauthmethodc.c:95: Added "hostbased" to usable methods.
debug: SshAuthMethodClient/sshauthmethodc.c:95: Added "publickey" to usable methods.
debug: SshAuthMethodClient/sshauthmethodc.c:95: Added "password" to usable methods.
debug: Ssh2Client/sshclient.c:1493: Creating userauth protocol.
debug: client supports 3 auth methods: 'hostbased,publickey,password'
debug: SshUnixTcp/sshunixtcp.c:1227: using local hostname alphads20e
debug: Ssh2Common/sshcommon.c:541: local ip = 192.168.25.15, local port = 2363
debug: Ssh2Common/sshcommon.c:543: remote ip = 192.168.25.13, remote port = 22
debug: SshConnection/sshconn.c:1957: Wrapping...
debug: SshReadLine/sshreadline.c:3388: Initializing ReadLine...
debug: Remote version: SSH-1.99-OpenSSH_2.5.2p2
debug: OpenSSH: Major: 2 Minor: 5 Revision: 2
debug: Ssh2Transport/trcommon.c:1533: All versions of OpenSSH handle kex guesses incorrectly.
debug: Ssh2Transport/trcommon.c:1540: Remote version has rekey incompatibility bug.
debug: Ssh2Transport/trcommon.c:1929: lang s to c: `', lang c to s: `'
debug: Ssh2Transport/trcommon.c:1994: c_to_s: cipher aes128-cbc, mac hmac-sha1, compression none
debug: Ssh2Transport/trcommon.c:1997: s_to_c: cipher aes128-cbc, mac hmac-sha1, compression none
debug: Remote host key found from database.
debug: Ssh2Common/sshcommon.c:342: Received SSH_CROSS_STARTUP packet from connection protocol.
debug: Ssh2Common/sshcommon.c:392: Received SSH_CROSS_ALGORITHMS packet from connection protocol.
debug: server offers auth methods 'publickey,password,keyboard-interactive'.
debug: Ssh2AuthPubKeyClient/authc-pubkey.c:1602: adding keyfile "//.ssh2/id_rsa_2048_a" to candidates
debug: server offers auth methods 'publickey,password,keyboard-interactive'.
debug: Ssh2AuthClient/sshauthc.c:330: Method 'publickey' disabled.
debug: server offers auth methods 'publickey,password,keyboard-interactive'.
debug: Ssh2AuthPasswdClient/authc-passwd.c:117: Starting password query...
root's password:

Linux client is Redhat 7.1 with SSH
OpenSSH_2.5.2p2, SSH protocols 1.5/2.0, OpenSSL 0x0090600f.

Thanks inadvance
9 REPLIES
Ralf Puchner
Honored Contributor

Re: SSH2 no password

please use the search function, openssh is not the ssh version implemented in Tru64.
Help() { FirstReadManual(urgently); Go_to_it;; }
Ravi_8
Honored Contributor

Re: SSH2 no password

Hi

search for Tru64 ssh in hp site, that's the one which works( i had installed it long back)
never give up
Abdul Rahiman
Esteemed Contributor

Re: SSH2 no password

Hi,

Your problem is due to the fact that you are trying to interface SSH2(Tru64) with OpenSSH2(on Linux) version. It will still work as opposed to the previous replies.
There is subtle differences between these two versions and requires some additional steps inorder to setup the public key autherntication.

On Tru64,
1) Generate the dsa key pair, enter null passphrase when prompted.
# ssh-keygen -t dsa
2) Copy the created public key to the linux server,
# scp ~/.ssh2/id_dsa_2048_a.pub linuxserver:.ssh/
3) Create identification file in the .ssh2 directory as follows with your key file name,
# echo "IdKey id_dsa_2048_a" >> ~/.ssh2/identification

On Linux Server,
1)Import the SSH2 style public key to openSSH format,
# ssh-keygen -i -f id_dsa_2048_a >> ~/.ssh/authorized_keys2
2) Change the permission of the file,
# chmod 600 ~/.ssh2/authorized_keys2

Now you can try password less login from the Tru64 to Linux server,
Let me know how it goes.

regds,
Abdul.
No unix, no fun
Sivasingam Santhakumar
Frequent Advisor

Re: SSH2 no password

Gurus,

I am not using OpenSSH on Tru64. I am using official version from Tru64(HP site). I have already mentioned it on the top.

Abdul,

I have tried your method with no luck.
Abdul Rahiman
Esteemed Contributor
Solution

Re: SSH2 no password

--------------------------------------------------------------------------------
Siva,

My solution should work.. I've a working setup here and has been working for a while between Tru64 and Linux.

I have attached a more detailed setup doc here and follow the setup which is appropriate for your scenario. I guessed your's is scenario 5. Again, it is not seemless, you have to pay attention to even the minute details. I can help if you have further questions.

HTH,
Abdul.
No unix, no fun
Sivasingam Santhakumar
Frequent Advisor

Re: SSH2 no password

Abdul,

I have tried your detailed steps with thanks. But I can't run ssh-add as I am using 2048 bit key, as you see the message:

alphads20e#ssh-add
Adding identity: //.ssh2/id_dsa_1024_a.pub
Public key file //.ssh2/id_dsa_1024_a.pub does not exist.
Certificate file //.ssh2/id_dsa_1024_a.crt does not exist

My keys are id_dsa_2048_a.pub.

How can I force it?

Thanks
Abdul Rahiman
Esteemed Contributor

Re: SSH2 no password

Siva,

Are you using ssh-agent? I think you should first try to setup this to do public key based authentication before trying to do ssh-agent method. (ssh-add comes in the picture only when u do the ssh-agent part).
Follow the steps for the scenario 5 ((ssh.com, protocol 2)->(openssh, protocol 2)) in the document and you would be fine.
It will let you use the 2048 bytes dsa key.

regds,
Abdul.

No unix, no fun
Sivasingam Santhakumar
Frequent Advisor

Re: SSH2 no password

Abdul,

I tried your steps on RH9 with OpenSSH_3.5p1, SSH protocols. And I used -b options to use 1024 bits. It is working but on RH7.1 with OpenSSH_2.5.2p2, SSH protocols 1.5/2.0, I don't have ssh-keygen -i option so I can't covert the key. Any Idea?

Thanks for your time on this matter.

Siva
Sivasingam Santhakumar
Frequent Advisor

Re: SSH2 no password

Abdul,

I have sorted out by copying the authorization file from RH9 to RH7.1. It's working now.

Thanks again.