Security
cancel
Showing results for 
Search instead for 
Did you mean: 

SSO installation problem on Tru64

Vinod Malatkar
Occasional Visitor

SSO installation problem on Tru64



Windows SSO client setup script fails.

I have added entry in /etc/hosts for WIN2K KDC.
Synced the times on both master KDC and Client using time server.

# w2ksetup

Enter the name of the Windows 2000 domain. This is
in the form: domain.compaq.com - Typically the Windows
2000 domain is the same as the DNS domain.

Domain: [EXAMPLE.COM] DOMAIN.COM

Enter the hostname of a Windows 2000 domain controller.
The hostname should have an entry in the local /etc/hosts file
to ensure successful completion of this setup procedure.

Domain Controller: TESTDOM.example.com

Setup has detected the presence of a /etc/ldapcd.conf
file. Setup will replace this file.

Continue with setup? [y/n]? y
Saving old /etc/ldapcd.conf in /etc/ldapcd.conf-prev

To create the machine account, you must be logged in as root
and have admin kerberos credentials. For security reasons
Windows 2000 does not allow anyone to authenticate through kerberos
using the Administrator account. Therefore you must choose an
account other than the Administrator account that has admin
privileges. The username of an account must be in the Windows
2000 KDC.


Failed to initialize application...

Setup did not complete. Please check your configuration notes.
Then, please rerun /usr/sbin/w2ksetup

____________________________

I believe it is trying to run creacct -h hostname -u and failing.

What am i missing here?

kinit, klist kdestroy all fails with same error.

I have another box running same version. I noticed DCE is installed on it. When i run w2ksetup it complains about incompatible DCE componenet. Can DCE and SSO co-exists on same box?

kinit and klist runs fine on this system.

Any help is much appreciated.

3 REPLIES
Aaron Biver_2
Frequent Advisor

Re: SSO installation problem on Tru64

If you think creacct is failing, and you know other similar programs are failing, try running those by themselves and debugging the failures.

Secondly, it looks like you put in dummy values for the domain and domain controller. I believe that the process uses these values to do real work, so you may have problems if you make stuff up here.

Finally, I have heard that, in general , making sure all hosts are in /etc/hosts will prevent problems. It does not appear this is directly related, though it can't hurt to try.


Vinod Malatkar
Occasional Visitor

Re: SSO installation problem on Tru64

Aaron:

Thanks for quick response.

I am using real domain and domain controller name. I just made up the names here. I have KDC(FQDN) listed in /etc/hosts.

Manually ran creacct. No luck.

# kinit

Failed to initialize application...

[1] vinrush:/krb5
# creacct -h vinrush -u

Failed to initialize application...
[1] vinrush:/krb5# klist

Failed to initialize application...

Do we have truss or similar utility in Tru64?

Tru64 ver 5.1B PK4 is installed on the system.

I'm new to T64. Please help.
Vinod Malatkar
Occasional Visitor

Re: SSO installation problem on Tru64

Never mind. I got it woking after reinstalling Windows SSO client.

I wonder if DCE and SSO work on the same box? I am getting error when I try to run w2ksetup on a box running DCE.