Showing results for 
Search instead for 
Did you mean: 

Virtualvault Server Administration - Authorization Required

Felipo Soranz UX
Occasional Advisor

Virtualvault Server Administration - Authorization Required

When trying to log in to the VV Server Administration I receive the following message:

"Authorization Required
This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

Apache/1.3.14 Server at vault Port 80"

I tried to change the password from the console (passwd vaultadm) and it seemed to work (su vaultadm, worked...) but I still cannot login to the adm interface. Is there any other thing I need to do for that to work?
Honored Contributor

Re: Virtualvault Server Administration - Authorization Required

Do you get a password prompt before that "Authorization Required" message, or does the message appear immediately when trying to access the admin interface? Have you tried using another browser?

Could the vaultadm account be expired? Both password lifetime and account lifetime needs to be checked. (On normal HPUX, root can login at the console even if the password is expired. On VV, the "vaultadm" might have a similar special permission - but only on the console.)

Our VirtualVaults were removed from production about two years ago, and I no longer remember all the Vault-specific tricks I used to know. When I get back to work on Monday I could check my old documentation.

If the only administrative account is the default "vaultadm" and it has expired, it is a bit of a Catch-22 since the admin interface is the normal way to handle the user accounts on a Virtualvault. However, I seem to recall that editing /tcb/files/auth/v/vaultadm to "grant an extension" manually should be possible.
Felipo Soranz UX
Occasional Advisor

Re: Virtualvault Server Administration - Authorization Required

I still have access to the root account.

I've made a few checks in the server like:
- Password is correct and is not expired.
- Basic authentication is enabled, other restrictions concerning authentication are disabled:

Basic authentication: enabled

Restricted to user: unrestricted

Restricted to IP: unrestricted

Encryption: disabled

Client certificates: not required

- /etc/auth/subsystems/users seems to be OK
- /tcb/files/auth/v/vvadmin seems to be OK

The problem is that right now I don't have access to the server in question, but I will try other things latter.

Any suggestions of things I should be checking?