Security
cancel
Showing results for 
Search instead for 
Did you mean: 

Warning: the /usr/sbin/spell program is not available

Stuart Green
Frequent Advisor

Warning: the /usr/sbin/spell program is not available

Been living with this remark when changing passwords for a while, but have decided to ask how to fix this.

OS: Tru64 5.1B
2 REPLIES
Johan Brusche
Honored Contributor

Re: Warning: the /usr/sbin/spell program is not available


Stu,

Are yo sure it says "sbin", because spell is normally installed by the OSFDCMTEXT540 subset in /usr/bin/.
setld -i OSFDCMTEXT540 would tell you if it's installed correctly.

Is the system configured for C2 security, because that's the only environment I imagine that would verify the password password against a known word dictionary ?

Cheers,
JOhan.

_JB_
Ann Majeske
Honored Contributor

Re: Warning: the /usr/sbin/spell program is not available

Hi Stuart,


Johan is right, you must be running Enhanced Security to get that message. You can either disable triviality checking or install spell. Installing spell would be the better way to go as you would be reducing the level of security on your system if you disabled triviality checks. There's more information on triviality checks on the prpasswd man page. There's more information on Enhanced Security in the Security Administration manual.

Ann