Security
cancel
Showing results for 
Search instead for 
Did you mean: 

prpasswdd listening on different UDP ports

SOLVED
Go to solution
Simon Jespersen
Frequent Advisor

prpasswdd listening on different UDP ports

Hi!
We are running several tru64 5.1b systems and some tru64 clusters asswell, all runing enhanced security. I have just learned that the prpasswdd daemon have udp ports open, and i cannot figure out why and if they could be closed.

I would like to prevent that process to using those ports otherwise i need to know the port range and why it uses them. Can anyone help me.

hate:./init.d # lsof -i -Pn | grep prpasswdd
prpasswdd 453898 root 4u IPv4 0x6897fdc0 0t0 UDP *:819
prpasswdd 453898 root 5u IPv4 0xf86ed180 0t0 UDP *:822
hate:./init.d #


At this time i holds 819 and 822. But yesterday it was using UDP 602 and 604

2 REPLIES
Ann Majeske
Honored Contributor
Solution

Re: prpasswdd listening on different UDP ports

The prpasswdd has client and server processes that communicate via RPC. It is the RPC communications that use the UDP ports. See "man rpc" and "man prpasswdd" for more details.

I think the easiest thing to try is to just disable the prpasswdd on your systems. The prpasswdd is not necessary, it was added as a performance enhancement for large systems and clusters with (very) many simultaneous logins. Except in these cases it doesn't significantly improve logins. So, I'd try disabling the prpasswdd on my systems and only re-enable it if I had significant performance problems with logins.

The following information was missing from the prpasswdd man page, but was added in the most recent patch kit:

Note: The prpasswdd daemon is not required for proper functioning of the system or cluster; it was added to improve performance on systems and clusters with high login rates. If this enhancement is not needed, specify the following command on every node in a cluster to stop the prpasswdd daemon:

# /sbin/init.d/prpasswd stop

Also specify the following command once in the cluster to prevent prpasswdd from restarting on reboot:

# /usr/sbin/rcmgr -c set PRPASSWDD_ARGS '-disable'
Simon Jespersen
Frequent Advisor

Re: prpasswdd listening on different UDP ports

Thank you for at very good and useful answer