Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Server Clustering
cancel
Showing results for 
Search instead for 
Did you mean: 

CMU 7.1 - javaws Issue

SOLVED
Go to solution
BrentGee
Advisor

CMU 7.1 - javaws Issue

Hi Again:

 

Now I am trying to run the cmugui via my workstation (Mac OS X 10.8) instead of via the server itself. When I try to run the downloaded gui jar file from the command line, I get the same error that was presented in my previous post (CMU 7.1 - GUI Launch Issue).

 

However, this time, when I try to run the gui via the web browser, I get the following error and the application refuses to launch:

 

Java Web Start 1.6.0_65
Using JRE version 1.6.0_65-b14-462-11M4609 Java HotSpot(TM) 64-Bit Server VM
User home directory = /Users/brentg
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
0-5: set trace level to <n>
----------------------------------------------------
Missing Application Name: manifest attribute for: http://elder2.westgrid.ca:85/cmugui.jar
Missing Permissions manifest attribute for: http://elder2.westgrid.ca:85/cmugui.jar
Missing Codebase manifest attribute for: http://elder2.westgrid.ca:85/cmugui.jar
Missing Application Name: manifest attribute for: http://elder2.westgrid.ca:85/cmugui.jar
Missing Permissions manifest attribute for: http://elder2.westgrid.ca:85/cmugui.jar
Missing Codebase manifest attribute for: http://elder2.westgrid.ca:85/cmugui.jar
Missing Permissions manifest attribute for: http://elder2.westgrid.ca:85/jnlp/jogl-2.0-b66-20121101/jar/jogl-all.jar
Missing Codebase manifest attribute for: http://elder2.westgrid.ca:85/jnlp/jogl-2.0-b66-20121101/jar/jogl-all.jar
Missing Application Name: manifest attribute for: http://elder2.westgrid.ca:85/jnlp/jogl-2.0-b66-20121101/jar/jogl-all.jar
Missing Permissions manifest attribute for: http://elder2.westgrid.ca:85/jnlp/jogl-2.0-b66-20121101/jar/jogl-all.jar
Missing Codebase manifest attribute for: http://elder2.westgrid.ca:85/jnlp/jogl-2.0-b66-20121101/jar/jogl-all.jar
Ignored exception: java.security.cert.CertificateException: User terminated

 

I have no idea what to do with this. Java version on my Mac -

 

java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

Please can somebody help with these issues?

4 REPLIES
BrentGee
Advisor

Re: CMU 7.1 - javaws Issue

Made a little bit of progress here. I wrote the following quick script which makes certain that the proper JAVAWS is running:

 

#!/bin/bash

JAVA_CMD="/System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/javaws"
CMUGUI=~/Desktop/cmugui.cgi

xhost +206.12.24.165
$JAVA_CMD $CMUGUI &

exit 0

 

At least now the gui launches and I can see all of the monitoring tabs. However, when I try to enable admin mode, I get the following new error:

 

Cannot connect to display : localhost:43

 

So now I will begin troubleshooting this issue. We're getting there...

BrentGee
Advisor

Re: CMU 7.1 - javaws Issue

Based on your previous response (CMU 7.1 - GUI Launch Issue) the javaws aspect is not longer an issue. However, now I am trying to resolve the following issue and, hopefully, I don't need to start a new thread:

 

Cannot connect to display : localhost:43

 

I thought that maybe this was a firewall issue. However, I have opened the following ports on the server:

 

tcp dpt:85 (this is the port we use instead of port 80 for the cmu web stuff)
tcp dpt:1099
tcp dpt:49150

 

And there is no firewall running on my workstation. Am I missing something? What else can I do to troubleshoot the issue?

Rakshika
Advisor
Solution

Re: CMU 7.1 - javaws Issue

>> Cannot connect to display : localhost:43

This error was seen while launching CMU GUI or xterm ?

 

And please open following ports also on managemnet node: 

x server port: 6000

ssh port: 22

 

Hope this solves your problem!

BrentGee
Advisor

Re: CMU 7.1 - javaws Issue

Thank you. Worked like a charm.