HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Clustering
cancel
Showing results for 
Search instead for 
Did you mean: 

CMU will not open after JDK Upgrade on Desktop

 
hwon
Occasional Visitor

CMU will not open after JDK Upgrade on Desktop

I installed JDK 1.8 on my desktop. Now, CMU GUI will not launch. There are no errors that appear. So I removed JDK1.8 and left previous JDK 1.7. There should be no references to JDK1.8 in my $PATH.  However, it still won't work.

1 REPLY
Alok_Pandey
Advisor

Re: CMU will not open after JDK Upgrade on Desktop

Hello,

What is the CMU version?
What is the exact jre/jdk version used on cmu server and gui client node(both 1.8 and 1.7)?

Are you launching GUI on head node itself or other workstation?
What is the OS on the node from where GUI is launched?

>> There should be no references to JDK1.8 in my $PATH.  However, it still won't work.
Please ensure that java plugin (used for launching jnlp files) for the browser points to the corect jdk path.

Please enable java console on GUI client using below procedure (1) and check the complete java stack trace in the console for any errors during GUI launch.
Also clean the java cache using procedure (2) and retry launching the GUI.

  1. How to enable java console:
           open Java Control Panel -> click on “Advanced” tab -> Java Console -> select “Show console” radio button -> click “Apply” button -> click “Ok” .
  2. To clear java cache using the Java Control Panel applet.

       On Windows GUI client nodes:
              Control panel→java→General Tab→Temporary internet files→Settings→Delete files        
       On Linux GUI client nodes, run the appropriate tool (for example, jcontrol) to access the Java Control Panel.

-
Alok