Server Clustering
Showing results for 
Search instead for 
Did you mean: 

Windows 2003 Cluster, disk shown as empty in disk management

Jani Pajula
Occasional Advisor

Windows 2003 Cluster, disk shown as empty in disk management

We have a two node Windows 2003 cluster, which uses EVA4000 as shared disk space. EVA has two disk groups, one for online and one for near-online disks. Last week we transferred few cluster disks to near-online group. We did this via mirrorclone with following steps:

1. create mirrorclone
2. shutdown both cluster nodes
3. unpresent original disks from cluster nodes
4. fracture mirror to make mirrored disk into two independent virtual disks
5. present mirrors with same lun id from near-online group
6. startup cluster nodes

Everything worked almost fine (only thing was little delay in problematic disk to bring back its original name), except yesterday when we tried to extend one of those disks. EVA extends the disk fine and it is even shown in disk management as free space. Diskpart is missing the whole volume and in upper window of disk management it says that disk is empty and the filesystem column is empty for problem disk. If I check from disk properties it says that the disk is raw. Anyhow, the disk is still usable for read and write through explorer and only thing that is missing is the disk name. Now the disk is named as "Local disk" instead of it's original name.

We took snapclone from the disk and presented clone to another server which couldn't mount the disk at all. I changed automount enabled with diskpart and unpresented/presented the disk back and then it was mounted but shown as empty in disk management. In explorer disk is usable and even the disk name has appeared to be the original one.

Tools chkdsk, chkntfs, fsinfo shows that NTFS is and the disk itself is ok.

Does anyone ever had similar problem and how was it repaired?


PS. I posted this message originally to Windows Server 2003 forum