Server Management - Remote Server Management

Disable iLO virtual NIC

 
TVR
Occasional Visitor

Disable iLO virtual NIC

Is there a way to totally disable the iLO virtual NIC?

When I do ipconfig, I get:

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . : local
Link-local IPv6 Address . . . . . : fe80::713b:58c9:c751:7486%6
IPv4 Address. . . . . . . . . . . : 16.1.15.2
Subnet Mask . . . . . . . . . . . : 255.255.255.252
Default Gateway . . . . . . . . . :

I want to disable the virtual NIC so it does not show in ipconfig. 

You can disable the virtual nic in the iLO web interface in security, but this is not what I want to do. I want to disable it at BIOS level.

Is this possible?

Thanks in advance.

 

13 REPLIES 13
ksram
HPE Pro

Re: Disable iLO virtual NIC

Hi,

Please let us know the Server Model number so that we can check the respective BIOS settings for the mentioned query.

iLO functionality

This setting specifies whether iLO functionality is available .

The following settings are valid:

  • Enabled (default) - The iLO network is available and communications with operating system drivers are active.

  • Disabled - The iLO network and communications with operating system drivers are terminated when iLO Functionality is disabled.

    For ProLiant Gen8 servers only: To re-enable iLO functionality, disable iLO security with the system maintenance switch, and then use the iLO RBSU to set iLO Functionality to Enabled. For more information about using the system maintenance switch, see the maintenance and service guide for server model.

    For ProLiant Gen9 servers only: To re-enable iLO functionality, use the iLO 4 configuration utility (in the UEFI System Utilities) to set iLO functionality to enabled.

NOTE: iLO functionality cannot be disabled on ProLiant server blades or Synergy compute modules.

You may disanble the ILO Functionality referring the link : https://support.hpe.com/hpesc/public/docDisplay?docId=mmr_sf-EN_US000006561

You may refer the below link as well : https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=emr_na-a00045376en_us#N10012

Thank you

KSRam 

 

 

 

 

 

 


I work for HPE

Accept or Kudo

TVR
Occasional Visitor

Re: Disable iLO virtual NIC

The server I am working on is a HPE ML30 Gen10

ksram
HPE Pro

Re: Disable iLO virtual NIC

Hi,

Please try the following steps : 

1. During the server startup sequence after installing the module, press F9 in the POST screen.
The System Utilities screen appears.
2. Select System Configuration | iLO 5 Configuration Utility.
The iLO 5 Configuration Utility screen appears.
3. Select Network Options, and then press Enter.
The Network Options screen appears.
4. Set the Network Interface Adapter field to Off / Disable, and then press Enter.
5. Press F10 to save your changes.
A message prompt to confirm that the iLO settings reset appears.
6. Press Enter to reboot the iLO settings.
7. Press Esc until the main menu is displayed.
8. Select Reboot the System to exit the utility and resume the boot process.
Check if the IP address of the iLO connector appears on the POST screen on the subsequent boot-up.

Thank you


I work for HPE

Accept or Kudo

TVR
Occasional Visitor

Re: Disable iLO virtual NIC

Hi

Thanks for your reply.

However, your answer disables the iLO completely. I still need to use iLO.

When I set the Network Interface Adapter to Off/Disable, I lose the ability to specify the DNS Name and the iLO IP address is "Disabled" on the boot-up screen.

I go back to my original question, that when I do ipconfig, I don't want to see the Virtual NIC IP 16.1.15.2.

Any thoughts on this?

Thank you

ksram
HPE Pro

Re: Disable iLO virtual NIC

Hi,

You can disable the Virtual NIC from ILO GUI.

Login to ILO (as Administrator) > Security > Access Settings > Click on Edit Option Next to ILO > Unselct the option "Virtual Nic" and apply.

You may have to "reset ILO" after applying the settings.

Also ILO should be updated to 140 or later version. You can refer the link to update the ILO : https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_f0ad4364410c4ea19f326434aa#tab3

(To update to iLO 5 version 2.10 or later, you must have a minimum iLO 5 version of 1.40)

Please confirm if it helps.

Thank you


I work for HPE

Accept or Kudo

ksram
HPE Pro

Re: Disable iLO virtual NIC

Hi,

Please confirm if the steps shared were helpful.

If you feel this was helpful please click the KUDOS! Thumbs below!

Thank you


I work for HPE

Accept or Kudo

Peterari
New Member

Re: Disable iLO virtual NIC

Hi

From GUI - this is acceptable for few servers... We need script solution. For automatic server build this "feature" is serious issue...

Redfish variable for write? Or powershell command update?
Thank for info

ksram
HPE Pro

Re: Disable iLO virtual NIC

Hi @Peterari ,

This is the Scripting and Command Guide : https://support.hpe.com/hpesc/public/docDisplay?docId=a00018323en_us 

But I couldnt find the details for Virtual Nic. Please check the document once and see if thats useful.

I shall check too.

Thank you


I work for HPE

Accept or Kudo

t_summers
New Member

Re: Disable iLO virtual NIC

I have this same problem.  Did you get an answer???

In RH7.4 a device is shown in ls -l /sys/class/net with link to USB finding it comes from iLO Virtual NIC enumerated as:
enp1s0f4u4s

Which shows in ifconfig as vNIC and /etc/sysconfig/network-scripts/ifcfg-vNIC

It auto plumbs on boot with 16 dot address, which we don't want.

So remember this is in iLO it's not going to be in BIOS.

The fact iLO config shows in area for RBSU in Gen10 is simply because UEFI functionality this is how it works compared to old BIOS.

With that said- this means that most likely to solve this will be via hponcfg and scripting an XML.
Looking in here, this may be some hidden option likie oem_HPE Restful API kind of was for a while.
This section from iLO webpage directly appears in iLO in area /map1/config1, see output of section below:
=================================
Targets
Properties
oemHPE_mapenable=yes
oemHPE_timeout=30
oemHPE_rbsuenable=yes
oemHPE_rbsulogin=no
...
oemHPE_ipmi_dcmi_overlan_enable=no
oemHPE_ipmi_dcmi_overlan_port=623
oemHPE_ribcl_status=yes
oemHPE_webserver_status=yes
oemHPE_webgui_status=yes
oemHPE_virtual_media_status=yes
oemHPE_remote_console_status=yes
================================
The section in iLO webpage sits right below the IPMI/DCMI stuff like listed above.
So the question becomes:
What is the name of the variable so we can disable via XML from hponcfg script?
 I don't know / think CONREP will handle this.
But I will ask my work colleague about it if he can find anything in conrep on Tuesday (assuming I remember after long holiday).

Any update from HPE is appreciated on it, as would like to script this also for large # Gen10 servers.

Best Regards,

Ted