Server Management - Remote Server Management

Failure during ILO firmware upgrade

New Member

Failure during ILO firmware upgrade

During the firmware upgrade of an ILO from version 1.41 to version 1.55 my Web interface crashed. ;o((
I tried to apply the patch again but I received a warning message 'Another user is already busy to upgrade the firware, plaese wait ' (it is not the correct message but somethings like that)
I tried to reset the RIB but now I cannot connect to the RIB anymore !!

What's the solution ?
I know that we can upgrade when booting from floppy but this server is in a remote site and we have nobody on site to able to reboot a server !!
Byron Zhu
New Member

Re: Failure during ILO firmware upgrade

If you attempt to upgrade the iLO firmware and it does not respond, does not accept the firmware upgrade, or is terminated before a successful upgrade, the following options are available:

- iLO network flash recovery
- ROMPaq

You can find the detail in the Integrated Lights-Out User Guide (Page240)
Junior Yharte
Trusted Contributor

Re: Failure during ILO firmware upgrade

Sounds like the F/W upgrade never completed so a flash recovery will need to be done. The problem will be the iLO over-ride switch... it will need to be flipped on before you re-flash the firmware.
Honored Contributor

Re: Failure during ILO firmware upgrade

You might try this before you punt...

First, try to update iLO using the online firmware update component. If that works, then you are done!

Plan B:
Create an iLO ROMPAQ firmware update diskette.
Verify that it works locally.
Connect it to the remote system using virtual media.
Reboot that host using iLO and Remote console.
Run the ROMPAQ (virtual media + Remote Console).
Note that your remote session abruptly terminates when ROMPAQ completes.
Reconnect to iLO after a few minutes.
Remotely reboot the host.

This is a pretty risky attempt to recover from your current situation, but there is a chance that it will work. If it does not work, chances are that the host will be unusable- partially booted to ROMPAQ and waiting for user input.

Plan C:
If you do not want to take the chance, you will have to request someone locally to boot the host and use ROMPAQ to update iLO

If that fails, a local user must:
disconnect power,
set the iLO security override switch,
power up,
power down,
clear the iLO security override switch,
remove the floppy,
and reboot.