Server Management - Remote Server Management

HPEiLOCmdlets and iLO3

Go to solution
Trusted Contributor

HPEiLOCmdlets and iLO3

It appears that updating to HPEiLOCmdlets version has broken being able to administer iLO3 servers.

I have also tried the same command that worked with version and it also fails.

Example (iLO Firmware Upgrade)


$connection = Connect-HPEiLO $server -Username $username -Password $password -DisableCertificateAuthentication -ErrorAction SilentlyContinue -WarningAction SilentlyContinue
Update-HPEiLOFirmware -Connection $connection -Location "D:\HP\ilo3_190.bin" -confirm:$false

WARNING: Update is in progress, this might take several minutes.
Update-HPEiLOFirmware : []: Firmware flash failed.
The remote server returned an error: (400) Bad Request.
At line:1 char:1
+ Update-HPEiLOFirmware -connection $connection -Location "D:\HP\ilo3_1 ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: (:) [Update-HPEiLOFirmware], Exception
    + FullyQualifiedErrorId : HPE.iLO.Cmdlet.UpdateHPEiLOFirmware

I have tried Update-HPEiLOFirmware in version and version (shown below) (when it worked before) and the same error is received.


Remove-Module -Name HPEiLOCmdlets
Import-Module -Name HPEiLOCmdlets -RequiredVersion

Can multiple versions of the HPEiLOCmdlets modules not work? Will the newest cmdlet always take precendence?

Updating the iLO3 firmware works using the oldest cmdlet, back when HPiLOCmdlets had to be downloaded and installed.

Update-HPiLOFirmware -Server -Username username -Password password -Location "D:\HP\ilo3_190.bin" -confirm:$false -DisableCertificateAuthentication

Is there a plan to have the iLO3 functionality working with HPEiLOCmdlets again or will I have to modify all of my scripts to work with the older cmdlets?

Example 2 (SSL Cert CSR)


CSR requests in iLO also fail with version and also fail when running the same cmdlet in

Start-HPEiLOCertificateSigningRequest -Connection $connection -State "MyState" -Country "US" -City "MyCity" -Organization "MyOrg" -OrganizationalUnit "MyTeam" -CommonName "server1").StatusInfo
             Category Message                AffectedAttribute
             -------- -------                -----------------
FeatureSupportability Feature not supported. {}

It is really upseting that is one step up (fixes CSR signing with iLO4 and -IncludeiLOIP) but two steps back (breaks all iLO3 administration). Will this problem be addressed at all?



Re: HPEiLOCmdlets and iLO3


 Scripting Tools ( Jul 2018)) is not supported with iLO3.Please read the release notes for more clarification.

Supported Devices and Features: Scripting Tools for Windows PowerShell : iLO cmdlets supports iLO 4 and iLO 5 devices.

 You can install scripting Tools for : iLO cmdlets for iLO 3 Mar 2018). Please read the release notes for more clarification.

 Supported Devices and Features:Scripting Tools for Windows PowerShell : iLO cmdlets supports iLO 3 and iLO 4 devices.


Sanjeev Goyal

I am a HPE Employee

Accept or Kudo

Trusted Contributor

Re: HPEiLOCmdlets and iLO3

Thanks. This is what I ended up doing. I have had to update existing scripts to use older cmdlets if iLO3 is detected.