Server Management - Remote Server Management

Re: ILO 5 boots ISO from virtual CD but will not use it for the software repository

 
Cindy Yoho
Occasional Advisor

ILO 5 boots ISO from virtual CD but will not use it for the software repository

I have a new DL360 Gen10 server which I want to install Oracle linxu on.   I have an ISO file with the OS, and the server sees the ISO mounted as a virtual CD/DVD.  However, when choosing the location of the software repository during the setup for installation, it does not allow me anything but HTTP//, HTTPS://, ftp:/./ or NFS.  How do I tell it to use the virtual CD/DVD it just booted off of.   The ISO is still mounted.   

Running ILO version 2.3 August 24, 2020

3 REPLIES 3
SanjeevGoyal
HPE Pro

Re: ILO 5 boots ISO from virtual CD but will not use it for the software repository

Hello,

 

Please follow the below option.

 

Option:1

 

You can mount the Virtual CD/DVD-ROM as a normal CD/DVD-ROM device by using the following

command:

mount /mnt/cdrom1

SuSE Linux Enterprise Server—The Virtual CD/DVD-ROM can be found at /dev/scd0, unless

a USB-connected local CD/DVD-ROM is present. In that case, the Virtual CD/DVD-ROM

uses /dev/scd1.

You can mount the Virtual CD/DVD-ROM as a normal CD/DVD-ROM device by using the following

command:

mount /dev/scd0 /media/cdrom1

 

Option:2

HPE iLO 5 1.30 User Guide (Follow the page no#155)

http://itdoc.hitachi.co.jp/manuals/ha8000v/hard/Gen10/iLO/880740-004_en.pdf

 

Mounting a USB Virtual Media CD/DVD-ROM on Linux systems

Procedure

1. Log in to iLO through the web interface.

2. Start the .NET IRC or Java IRC.

3. Select the Virtual Drives menu.

4. Select the CD/DVD-ROM to use.

5. Mount the drive by using the following commands:

• For Red Hat Enterprise Linux:

mount /dev/cdrom1 /mnt/cdrom1

• For SuSE Linux Enterprise Server:

mount /dev/scd0 /media/cdrom1

 

Please let me know if the issue still persists.

 


I am a HPE Employee

Accept or Kudo

Cindy Yoho
Occasional Advisor

Re: ILO 5 boots ISO from virtual CD but will not use it for the software repository

Hi, Thanks for the reply.   The version of ilo I am using (2.3) has a button at the top of the console screen that allows me to  mount a virtual cd/dvd.  I have done that, and the new server boots up using that ISO.   It boots into the Linux installation screen, which then asks (among other things) what repository I want to use for the install.  The virtual cd/dvd is not an option.   The only options are HTTP, HTTPS, NFS and FTP.  When I check the virtual cd/dvd it still has the ISO mounted, but it doesn't seem to think it is a repository (it is, I have installed 2 virtual guests using it).

The other method you suggest (method 1) requires that I have a command line screen to type the mount command in, and I don't have that yet.  I only have the install gui that booted from the ISO.   

 

SanjeevGoyal
HPE Pro

Re: ILO 5 boots ISO from virtual CD but will not use it for the software repository

Hello,

I would suggest you have a proper case be logged with HPE, and share the appropriate logs for further analysis.


I am a HPE Employee

Accept or Kudo