Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO XML Script error

SOLVED
Go to solution
TimGPR
Occasional Advisor

ILO XML Script error

hope that anybody can help me. I'm trying to modify the network settings of an integrated ILO card but i get an xml script error. Out of the 10 servers, 5 are giving me script errors.

Error MSG:
-------------------------------------------------
Status = 0x1
Message = Syntax error: Line #0: syntax error near "<" in the line: ">"
Script failed
-------------------------------------------------
-I got HP Lights-Out Online Configuration Utility version 1.5.2.0
-ILO Management Interface w2k/w2k3 Driver version 1.7.2195.0
- ILO 1.41 or above firmware

Script:
-------------------------------------------------
















































-------------------------------------------------
I don't know what error "LOCFG VERSION="2.24" means ?
11 REPLIES
KarloChacon
Honored Contributor

Re: ILO XML Script error

hi

just to clarify

this script (of course changing IP, and so on)
works fine in 5 server but not in other five servers? Am I right?

any difference between the ones that works and the ones that dont? firmware version for example?

regards

Didn't your momma teach you to say thanks!
TimGPR
Occasional Advisor

Re: ILO XML Script error

Yes, that's correct. It's not working on the other 5 servers. They r W2k servers and W2k3 sp1 machines. ILO firmware = 1.41.

The working servers have different firmware. 1.41, 1.51, 1.84 and 1.89.
woby
Advisor

Re: ILO XML Script error

Hi timGPR,

try this:









have a nice day
t.
TimGPR
Occasional Advisor

Re: ILO XML Script error

Hi there Woby,

Unfortunately, same error.

Message = Syntax error: Line #0: syntax error near "<" in the line: "
acartes
Honored Contributor

Re: ILO XML Script error

Try updating one of the servers failing to the current iLO firmware version, and then re-testing the script.
TimGPR
Occasional Advisor

Re: ILO XML Script error

Hi there arcates,

The failing servers already got firmware 1.41, do u mean upgrading the servers to the latest firmware 1.91 ?
KarloChacon
Honored Contributor

Re: ILO XML Script error

hi

no it means update it to 1.43 because I think you have ilo2 and the latest version is 1.43

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=1135772&prodTypeId=18964&prodSeriesId=1146658&swLang=8&taskId=135&swEnvOID=1005#29213

regards
Didn't your momma teach you to say thanks!
Blazhev_1
Honored Contributor
Solution

Re: ILO XML Script error

Hi,

check :

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00294268/c00294268.pdf

on page 53 :

You must incorporate
into the script sent to iLO 2. You can place this tag in either the Perl script or the XML script. Placement of this tag is important.

And here is the download for LOCFG 2.25 :

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=397634&prodNameId=3288132&swEnvOID=1005&swLang=8&mode=2&taskId=135&swItem=MTX-UNITY-I23909

Seems like the script expects you to send the script from LOCFG, not from HPONCFG, like in your case, and waits for this line...

requirements for the tools are listed in the doc too - The best thing will be to update the iLO FW & iLO drivers, there is a 1.7.2 version of hponcfg, but yours is ok.

You can download this tool and add then it must function ok.

regards,
Pac







TimGPR
Occasional Advisor

Re: ILO XML Script error

I updated the ILO firmware from all the failing machines to 1.89 and then re-executed the script. It worked like a charm. All machines r reachable now.

Although the script claims firmware 1.40 or above is enough this isn't the case.

Thankz all 4 ur replies :D
TimGPR
Occasional Advisor

Re: ILO XML Script error

I updated the ILO firmware from all the failing machines to 1.89 and then re-executed the script. It worked like a charm. All machines r reachable now.

Although the script claims firmware 1.40 or above is enough this isn't the case.

Thankz all 4 ur replies :D
acartes
Honored Contributor

Re: ILO XML Script error

>> Although the script claims firmware 1.40 or above is enough this isn't the case.


That comment was added prior to first-generation iLO version 1.40.

iLO 2 is a different product, and does not have a specific firmware version requirement for this script.