Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO schema-less AD integration Problem

Ronny Brehm
Occasional Advisor

ILO schema-less AD integration Problem

I set up about 10 ILO and ILO2 cards with schema-less AD integration. I noticed that when I connect to them via DNS name it works. But if I connect to them directly through IP then it doesn't.

Anyone have any ideas?
6 REPLIES
Ronny Brehm
Occasional Advisor

Re: ILO schema-less AD integration Problem

Not sure why this helped but once I put a user context string in that pointed to my Users directory it works via IP and DNS name.

Thanks,
M.S.Srivatsa
Valued Contributor

Re: ILO schema-less AD integration Problem

Refer to the white paper,
Integrating HP ProLiant Lights-Out processors with Microsoft® Active Directory
http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c00190541/c00190541.pdf

One other suggestion is,
Please modify the following settings from the Network settings page which would help the directory user to login with "Email"(loginname@domain) and "NetBios name"(domain/loginname) formats.

Primary/Secondary/Tertiary DNS Server
The Primary/Secondary/Tertiary DNS server IP address should be same as the Active directory server IP address.

Domain Name
This domain should be same as the domain for which the Active directory server is configured.

Ronny Brehm
Occasional Advisor

Re: ILO schema-less AD integration Problem

Do you know which security settings inside Internet Explorer give the ability to use domain\username? I know it requires ActiveX and I was able to get it to work on my box by setting the local intranet security settings to low. I can't seem to isolate the exact setting that allows it so I can tell everyone else that will use ILO how they can use domain\username instead of their full name.

Thanks,
M.S.Srivatsa
Valued Contributor

Re: ILO schema-less AD integration Problem

Please enable the ActiveX controls in the internet explorer(IE 6) as under:
1.Goto Internet explorer->security
2.Choose the appropriate sites
3.set the ActiveX controls to enable/prompt.
Please refer to Page 172 of the following iLO user guide which gives information on troubleshooting directory issues.
http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c00209014/c00209014.pdf
Ronny Brehm
Occasional Advisor

Re: ILO schema-less AD integration Problem

Found it. Under IE7 you have to set the "Initialize and script ActiveX controls not marked as safe for scripting" to prompt or enabled for the Local Intranet Zone. Once this is set I can connect directly with domain\username and username@domain.

This request can be closed.

Thanks again.
Ronny Brehm
Occasional Advisor

Re: ILO schema-less AD integration Problem

Done