Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem configuring iLO 3 Network using HP Lights-Out Configuration Utility: cpqlocfg.exe

Jimmy Tn
Occasional Advisor

Problem configuring iLO 3 Network using HP Lights-Out Configuration Utility: cpqlocfg.exe

Hi folks,

I’d like to share my experience with configuring iLO 3 using the utility HP Lights-Out Configuration Utility cpqlocfg.exe (not to confuse with HP Lights-Out Online Configuration Utility). I’d also like to know if anyone out there has had similar problems.

First off: I have double-checked that I’m using the latest version of cpqlocfg.exe (v. 3.00 suitable for iLO 3). I have also checked that the latest xml sample files for iLO 3 is used (windows-LOsamplescripts3.00.0-2).
Further more, iLO 3 version 1.05 is applied.

I have problem configuring the Network module.
I’m getting different results when I’m running this cpqlocfg command together with its parameters, trying to configure the Network with the help of a modified sample file (Mod_Network_Settings.xml).
On one server the command works great. On another the execution halts in the middle of the run and the iLO device hang completely. Only pulling the power cords is releasing the hang state.
Now, when I run the exact same command again on the working server, it might fail. Also running the command on a server previously failing, might suddenly work. You see my point.
I have not found any common factors that make things work out or not work out.
I have tried to modify the xml file in numerous ways, changing different parameters, leaving out some, without coming closer to a solution.

All other modules I have tested are working great.
I have similar configuration scripts for iLO 1 and iLO 2 and there have never been any problem with them.

All iLO devices are connected to the same separate iLO network with the same switch configuration.

Have anyone faced similar problem with this kind of remote configuration?
5 REPLIES
Jan Soska
Honored Contributor

Re: Problem configuring iLO 3 Network using HP Lights-Out Configuration Utility: cpqlocfg.exe

Hello,
I noticed problem like yours here in forum, probably you have to wait wor new version.

My sugestion is to raise support call to HP to push them little.

Jan
Ken Krubsack
Trusted Contributor

Re: Problem configuring iLO 3 Network using HP Lights-Out Configuration Utility: cpqlocfg.exe

Couple of things.

1 - I believe this utility has been upgraded to 3.1.
2. ILO3 FW 1.10 has been released. tat has helped me a lot.
Tony Okusanya
Occasional Contributor

Re: Problem configuring iLO 3 Network using HP Lights-Out Configuration Utility: cpqlocfg.exe

I have a similar problem getting ILO3 to work correctly as it seems to crash whenever I send the configuration script using cpqlocfg.exe
Jimmy Tn
Occasional Advisor

Re: Problem configuring iLO 3 Network using HP Lights-Out Configuration Utility: cpqlocfg.exe

Thank you both. I will keep my eyes open for version 3.1 of the utility (haven't found any yet).
I have made some tests with the new FW but it is still unpredictable.

BR / Jimmy
Ken Krubsack
Trusted Contributor

Re: Problem configuring iLO 3 Network using HP Lights-Out Configuration Utility: cpqlocfg.exe

You're right - the online version of the utility has been upgraded to 3.10, not the program you're after.

Exactly what you said at the bginning of your post - not to confuse with HP Lights-Out Online Configuration Utility. Duh.