Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

Set-HPEiLOIPv4NetworkSetting and iLO4

SOLVED
Go to solution
Highlighted
rgb99
Trusted Contributor

Set-HPEiLOIPv4NetworkSetting and iLO4

In version 2.0.0.1, cmdlet Set-HPEiLOIPv4NetworkSetting does not seem to apply certain parameters to iLO4.

Parameters that will not apply no matter what:
-DNSServerType
-DNSServer
-DomainName
-WINSServerType
-WINSServer

Parameters that do work:
-InterfaceType
-RegisterDDNSServer
-RegisterWINSServer

PS D:\> $connection = Connect-HPEiLO -Server 1.1.2.2 -Username admin -Password password -DisableCertificateAuthentication
PS D:\> $connection

IP                               : 1.1.2.2
Hostname                         :
ConnectionType                   : RIBCL
DisableCertificateAuthentication : True
iLOGeneration                    : iLO4
iLOFirmwareVersion               : 2.61
iLOResetWaitTimeout              : 0
IsConnected                      : True
ServerFamily                     : ProLiant
ServerGeneration                 : Gen8
ServerModel                      : BL460c
Timeout                          : 30
Username                         : admin
PS D:\> $DNSServerTypes = ,@("Primary","Secondary","Tertiary")
PS D:\> $DNSServers = ,@("3.3.3.3", "4.4.4.4", "5.5.5.5")
PS D:\> Set-HPEiLOIPv4NetworkSetting -connection $connection `
>> -InterfaceType Dedicated `
>> -RegisterDDNSServer Enabled `
>> -RegisterWINSServer Disabled `
>> -DNSServerType $DNSServerTypes `
>> -DNSServer $DNSServers -Verbose
VERBOSE: Performing the operation "Set-HPEiLOIPv4NetworkSetting" on target "IP: 1.1.2.2".
VERBOSE: [Set-HPEiLOIPv4NetworkSetting] Executing the cmdlets with 1 task serially.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Validating input parameter values.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Validating Cmdlet supportability.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Validating parameter supportability.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Validating for set of parameters to be given.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Creating web request.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Writting request stream.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Getting web response.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][1.1.2.2]: Processing RIBCL response.

It appears to execute but some parameters do not set at all.

What am I missing here?

2 REPLIES
GokulKS
Trusted Contributor
Solution

Re: Set-HPEiLOIPv4NetworkSetting and iLO4

Hi,

You have missed including -DHCPv4DNSServer and DHCPv4WINSServer which need to be disabled.

Otherwise by default DHCP enabled IP's will take DNS and WINS server settings from DHCP server.

$out = Set-HPEiLOIPv4NetworkSetting -connection $con16 -InterfaceType Dedicated -RegisterDDNSServer Enabled -DNSServerType $DNSServerTypes -DNSServer $DNSServers -RegisterWINSServer Enabled -Verbose -DHCPv4DNSServer Disabled -WINSServerType $WINSTypes -WINSServer $WINSServers -DHCPv4WINSServer Disabled

Try this and let me know i hope it should work i tried it on iLO4.

Thanks,

Gokul

Don't forget to give Kudos if the problem got resolved or like suggestion.
rgb99
Trusted Contributor

Re: Set-HPEiLOIPv4NetworkSetting and iLO4

Thank you, that worked. Holy cow was that frustrating!! I also needed to add -DHCPv4DomainName Disabled for the DomainName parameter to update.