Server Management - Remote Server Management

Set-HPEiLOIPv4NetworkSetting and iLO4

Go to solution
Trusted Contributor

Set-HPEiLOIPv4NetworkSetting and iLO4

In version, cmdlet Set-HPEiLOIPv4NetworkSetting does not seem to apply certain parameters to iLO4.

Parameters that will not apply no matter what:

Parameters that do work:

PS D:\> $connection = Connect-HPEiLO -Server -Username admin -Password password -DisableCertificateAuthentication
PS D:\> $connection

IP                               :
Hostname                         :
ConnectionType                   : RIBCL
DisableCertificateAuthentication : True
iLOGeneration                    : iLO4
iLOFirmwareVersion               : 2.61
iLOResetWaitTimeout              : 0
IsConnected                      : True
ServerFamily                     : ProLiant
ServerGeneration                 : Gen8
ServerModel                      : BL460c
Timeout                          : 30
Username                         : admin
PS D:\> $DNSServerTypes = ,@("Primary","Secondary","Tertiary")
PS D:\> $DNSServers = ,@("", "", "")
PS D:\> Set-HPEiLOIPv4NetworkSetting -connection $connection `
>> -InterfaceType Dedicated `
>> -RegisterDDNSServer Enabled `
>> -RegisterWINSServer Disabled `
>> -DNSServerType $DNSServerTypes `
>> -DNSServer $DNSServers -Verbose
VERBOSE: Performing the operation "Set-HPEiLOIPv4NetworkSetting" on target "IP:".
VERBOSE: [Set-HPEiLOIPv4NetworkSetting] Executing the cmdlets with 1 task serially.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Validating input parameter values.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Validating Cmdlet supportability.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Validating parameter supportability.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Validating for set of parameters to be given.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Creating web request.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Writting request stream.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Getting web response.
VERBOSE: [Set-HPEiLOIPv4NetworkSetting][]: Processing RIBCL response.

It appears to execute but some parameters do not set at all.

What am I missing here?


Re: Set-HPEiLOIPv4NetworkSetting and iLO4


You have missed including -DHCPv4DNSServer and DHCPv4WINSServer which need to be disabled.

Otherwise by default DHCP enabled IP's will take DNS and WINS server settings from DHCP server.

$out = Set-HPEiLOIPv4NetworkSetting -connection $con16 -InterfaceType Dedicated -RegisterDDNSServer Enabled -DNSServerType $DNSServerTypes -DNSServer $DNSServers -RegisterWINSServer Enabled -Verbose -DHCPv4DNSServer Disabled -WINSServerType $WINSTypes -WINSServer $WINSServers -DHCPv4WINSServer Disabled

Try this and let me know i hope it should work i tried it on iLO4.



I am a HPE Employee

Accept or Kudo

Trusted Contributor

Re: Set-HPEiLOIPv4NetworkSetting and iLO4

Thank you, that worked. Holy cow was that frustrating!! I also needed to add -DHCPv4DomainName Disabled for the DomainName parameter to update.

Occasional Visitor

Re: Set-HPEiLOIPv4NetworkSetting and iLO4

Unfortunatelly it does not work if you want to change DNS server settings when DHCP is disabled (tested on latest HPEiLOCmdlets module version The StatusInfo message is "DHCP is currently disabled, enable DHCP to use any DHCP setting"

Trusted Contributor

Re: Set-HPEiLOIPv4NetworkSetting and iLO4

@olafT , I recommend posting the problem in a new thread since this particular issue was Resolved over a year ago.

However, what works for me when using version (needed for certain iLO3 settings that don't apply with a newer version of the cmdlets)

Set-HPEiLOIPv4NetworkSetting -connection $connection `
	-InterfaceType Dedicated `
	-DHCPv4NTPServer Disabled `
	-DHCPv4DNSServer Disabled `
	-DHCPv4DomainName Disabled `
	-DHCPv4WINSServer Disabled `
	-DHCPv4StaticRoute Disabled `
	-DNSName $DNSName `
	-DNSServerType $DNSServerTypes `
	-DNSServer $DNSServers `
	-RegisterDDNSServer Enabled `
	-DomainName $DomainName `
	-WINSServerType $WINSServerTypes `
	-WINSServer $WINSServers `
	-RegisterWINSServer Disabled -Wa SilentlyContinue | Out-Null
$DNSName = "dnsname-mng"
$DNSServerTypes = ,@("Primary","Secondary","Tertiary")
$DNSServers = ,@("", "", "")
$DomainName = ""
$WINSServerTypes = ,@("Primary","Secondary")
$WINSServers = ,@("", "")


Also, since I don't use IPv6, I also disable the options there.

Set-HPEiLOIPv6NetworkSetting -connection $connection `
	-InterfaceType Dedicated `
	-PreferredProtocol Disabled `
	-StatelessAddressAutoConfiguration Disabled `
	-DHCPv6StatefulMode Disabled `
	-DHCPv6SNTPSetting Disabled `
	-DHCPv6DNSServer Disabled `
	-DHCPv6StatelessMode Disabled `
	-RegisterDDNSServer Disabled -Wa SilentlyContinue | Out-Null


I hope this helps you out!